2

I have created a folder not in /home but on other volume which is free (eventually I'd like to share the folder via Samba).

I have found the path:

/media/xduser/kingstone

I did:

cd /media/xduser/kingstone
sudo mkdir share23
sudo chmod 777 -R share23
sudo chown -R xduser:xduser  /media/xduser/kingstone/share23

But when I ls, I see:

$ ls -li /media/xduser/kingstone
total 32
4 drwxr-xr-x 2 xduser xduser 32768 Dec  7 09:48 share23

Also, I cannot change permissions in the GUI. So, I see the share23 on another machine but cannot open it because of permissions.

This is the output of findmt:

$ sudo findmnt -T /media/xduser/kingstone/
TARGET                 SOURCE    FSTYPE OPTIONS
/media/xduser/kingstone /dev/sdc1 vfat  rw,nosuid,nodev,relatime,uid=1001,gid=1001,fmask=0022,dmask=0022,codepage=437,iocharset=

How can I change the permissions?

14
  • Please edit your question to include the output of findmnt -T /media/xduser/kingstone
    – Raffa
    Dec 7, 2023 at 9:57
  • 2
    That filesystem doesn't support Linux permissions ... But, you can change fmask, dmask to 0000 or probably remove them from your mount options and use umask=0000 instead.
    – Raffa
    Dec 7, 2023 at 10:06
  • Also note that the permissions on the local machine are unlikely to be the problem on the remote machine. Those will depend on how the remote machine mounts the directory.
    – terdon
    Dec 7, 2023 at 10:06
  • @Raffa thank you. I see, it is FAT. I can format disk. What file system to use?
    – ZedZip
    Dec 7, 2023 at 10:24
  • Any *nix filesystem should support Linux type permissions ... EXT4 is the default on Ubuntu ... However, Windows will not be able to read it directly, so you can't mount it on Windows ... You'll need to mount it on a Linux machine and then, Windows can read it as a Samba share for example
    – Raffa
    Dec 7, 2023 at 10:30

1 Answer 1

2

It's a free world, but ...

Assuming you understand that granting full permissions of read, write, and execute and especially for the other group is going to compromise the security and probably integrity/existence (given the sticky bit isn’t set as well) of all files under that directory allowing anyone to view, modify and delete them beyond any possible recovery or even functional traceability ... So, not discussing that ... And skipping, as well, the fact that in most use cases not all those permissions need to be granted and some of them will suffice ... That’s for you to decide anyway as you will be the the only one who will suffer if your creation happens to be wanting to bite its creator back ... But, let’s hope this won’t happen as I have nothing that I can offer you in that situation except hope and backups if they existed.

Why are permissions not set?

Because your filesystem on that drive is of the FAT family and those folks don't understand or accept Linux type permissions.

Why is that filesystem mounted with such limited permissions anyway?

Because, it's mounted with the fmask=0022 and the dmask=0022 mount options and those masks translate to 0755 or rwxr-xr-x permissions for directories and "actually" 0644 or rw-r--r-- for regular files.

What are the options?

1
  • Thank you for the detailed answer. But I did not find yet a few things: I have re-formatted the HDD as ext4 volume, created a folder in terminal but not in GUI. What should I do next?
    – ZedZip
    Dec 8, 2023 at 9:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .