I do not use the wired Ethernet Card. It seems to me that, Ubuntu is always trying in boot time to check the network via eth0, Which consumes some times and I guess this may slow down the boot process a bit. My dmesg output is below (partial)

2012-06-11 23:06:47 Ubuntu-KDE  kernel  [    1.985592] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input5
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [    1.985651] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [    1.985693] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [    2.056261] firewire_core: created device fw0: GUID 00023f87af41fd7d, S400
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [    3.710435] EXT4-fs (sda9): mounted filesystem with ordered data mode. Opts: (null)
                                 A big time here.....
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   13.466642] ADDRCONF(NETDEV_UP): eth0: link is not ready
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.125296] Adding 1050620k swap on /dev/sda6.  Priority:-1 extents:1 across:1050620k 
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.226952] EXT4-fs (sda9): re-mounted. Opts: (null)
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.335012] snd_hda_intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.335091] snd_hda_intel 0000:00:1b.0: irq 45 for MSI/MSI-X
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.335128] snd_hda_intel 0000:00:1b.0: setting latency timer to 64
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.346410] input: Ideapad extra buttons as /devices/platform/ideapad/input/input6
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.428551] input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.436958] cfg80211: Calling CRDA to update world regulatory domain
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.476550] Linux video capture interface: v2.00
2012-06-11 23:06:47 Ubuntu-KDE  kernel  [   14.486385] uvcvideo: Found UVC 1.00 device USB 2.0 Camera (04f2:b008)

So, My question is How can I disable the Ethernet card completely, so that kernel will not try to use that?

  • The card would have to be disabled at the hardware level, if its an integrated card that may be hard to do, if it were an expansion NIC card, you could just remove itfrom the system. – Thomas Ward Jun 11 '12 at 17:58
  • 1
    Since the kernel messages are timestamped you can easily see how much time the kernel wastes. Does it seem excessive to you? – irrational John Jun 11 '12 at 18:33
  • 2
    It seems to me that it might be possible to disable any Ethernet-related kernel modules from being loaded, though I'm not sure how to properly do this (or I'd write an answer). – Eliah Kagan Jun 11 '12 at 19:31
  • 1
    @EliahKagan, Exactly what I am trying to do. disabling Ethernet-related kernel modules being loaded. – Anwar Jun 12 '12 at 4:52
  • I notice that 12.04 LTS installed from DVD doesn't have this problem. It only attempts to acquire an IP address after the boot sequence. – Thufir Aug 8 '13 at 22:41

Blacklist the NIC driver

  1. Create a blacklist file in /etc/modprobe.d/

Note that files in /etc/modprobe.d/ must have .conf suffix. Also naming modules in /etc/modprobe.d/blacklist.conf does not affect autoloading of modules by the kernel so you have to make your own file.

Example of a blacklist file: blacklist-ethernet.conf

blacklist driver_0     # eth0 by default

Note: here driver_0 is the name of your NIC driver. you can find the name of kernel driver for your LAN card by using the command lspci -v command in a terminal.
For Example my output was :

6:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
    Subsystem: Lenovo Device 3861
    Flags: bus master, fast devsel, latency 0, IRQ 46
    Memory at b8000000 (64-bit, non-prefetchable) [size=64K]
    Expansion ROM at  [disabled]
    Kernel driver in use: tg3
    Kernel modules: tg3

Here, I see the driver is tg3. so you need to write tg3(or your driver) in the place of driver_0.

  1. Generate modules.dep and map files by running: depmod -ae

  2. Recreate your initrd: update-initramfs -u

Plenty of info can be found here.

| improve this answer | |
  • I've just tried this, but same result – Anwar Jun 12 '12 at 9:39
  • @AnwarShah have you found the exact name of the ethernet module that is being loaded? Could you disable it with rmmod to test that you can disable it ? – pl1nk Jun 12 '12 at 12:47
  • I don't but will try soon – Anwar Jun 12 '12 at 13:31
  • Thanks for your great reply. I am accepting this, though it does not boost the speed very much. – Anwar Jun 12 '12 at 15:35

When booting, press the special key to enter your computer's BIOS configuration, before Ubuntu starts booting. Inside the BIOS, you should be able to disable the integrated NIC. If it is not available there, and this is a workstation PC, rather than a laptop, consult the manual for the motherboard (or for the computer itself, if a branded PC), and there should be a jumper to disable it on hardware. Make sure the computer is powered off, and unplugged before touching any jumpers though.

| improve this answer | |
  • 1
    I don't think AskUbuntu is made to send OP's to the hardware dungeon... – nanofarad Jun 11 '12 at 20:44
  • 1
    It is the best, and most correct answer. The OP asked a question, and I merely provide the best answer I can. That is exactly what AskUbuntu is made for. – dobey Jun 12 '12 at 1:35
  • In my bios, disabling NIC also disables USB booting feature. and I want to disable it so that it does not check the network in boot time – Anwar Jun 12 '12 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.