3

Hello I have Ubuntu MATE 22.04.03 LTS on a desktop computer. Today, suddenly, I cannot run any libreoffice program anymore. I get this error:

$ lowriter 
/usr/lib/libreoffice/program/javaldx: error while loading shared libraries: libreglo.so: cannot open shared object file: No such file or directory
Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libreglo.so: cannot open shared object file: No such file or directory

What can I do? Where should i get this file libreglo.so which apparently is missing?

2 Answers 2

2

I am not sure whether this is a solution or a workaround, however libreoffice seems to work again after inserting /usr/lib/libreoffice/program at the first place in the shell variable LD_LIBRARY_PATH. So inserted this line in my ~/.profile:

export LD_LIBRARY_PATH=:/usr/lib/libreoffice/program:/usr/lib:/usr/lib/x86_64-linux-gnu

After restart Libreoffice seems to work.

I found this suggestion here:

LibreOffice stopped working in Ubuntu 17.04

3
  • Interesting, looks like others have been having the same near-duplicate problem for a while, only now the file is actually missing in addition to being mis-configured somehow.
    – Xen2050
    Dec 6, 2023 at 12:16
  • Strange. On a fresh Ubuntu 22.04 install, this variable does not appear to be set. I also do not see it on Fedora. Is this a default install of LibreOffice?
    – vanadium
    Dec 7, 2023 at 7:57
  • No, it worked without problems until the other day. Maybe some recent installations i made generated conflicts, but now it is difficult for me to investigate this. Dec 7, 2023 at 13:09
0

I think your uno-libs-private package may be missing or has some corrupted files... it supplies the libreglo.so file (at /usr/lib/libreoffice/program/libreglo.so ).

Reinstalling that package should get the file back in the right place... assuming you don't already have the file. First you can check with a find:

find / -mount -iname "*libreglo.so*" 2>/dev/null

And if it doesn't find the file then give this a try: apt reinstall uno-libs-private

If the file is already on your system, it could still be corrupted and a reinstall should fix it. Or maybe something else has gone wrong with libreoffice, and it can't find the file... Maybe reinstalling all the libreoffice packages would help, or if not that sounds like a libreoffice bug...?


FYI, here's how I reached my conclusion:

I've got libreoffice installed and working, I tried the find command listed above, then dpkg -S [full path for file] to find what package supplies it.

2
  • 1
    HI thank you! I didn't in fact have that file, and after reinstalling uno-libs-private it appeared in the /usr/lib/libreoffice/program/ directory. However this was not enough, I had to put the path of that directory in my LD_LIBRARY_PATH variable. I posted an answer explaining this Dec 6, 2023 at 11:33
  • I guess LD_LIBRARY_PATH is not set by default (the system searches in the default directories, including /usr/lib. On your system, the variable appears to have been set to a different directory, so default directories are not anymore searched.
    – vanadium
    Dec 7, 2023 at 8:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .