I bought recently my Dell N 5110 and installed Ubuntu 12.0.4 LST X 64 Bit along with Windows 7. The problem I am facing is my touch pad is not recognized in ubuntu and tried installing alps (as I found some where in ubuntu forums but didn't worked well to the surprise it deleted even my touchpad which is working as mouse).

If any body having any idea on how sort out this issue please help me...i'm getting sick of each time holding and dragging my pages.

the result of

xinput list


⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                          id=12    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Power Button                                id=8    [slave  keyboard (3)]
    ↳ Sleep Button                                id=9    [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD                 id=10    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=11    [slave  keyboard (3)]
    ↳ Dell WMI hotkeys

Thanks in advance


I had a similar problem with my alps touchpad. It worked on 12.10, but not on 12.04. (Have you tried yours in 12.10?) I wanted 12.04, however, so what I ended up doing was testing newer and newer kernels. I ended up with the 3.6.3 kernel, and everything is working great. (If you try this, of course do the research & take the necessary precautions, e.g. back-up.)


Yes I have the same problem with my Dell 5110, the only viable solution to this so far is when navigating while searching the web is to double tap the scroll on the side of the window and keep your finger on the touchpad. As far as I'm concerned this dell touchpad didn't even work well in windows it's kind of hard to find, since it's incorporated within the pad itself, the touchpad on my girlfriends laptop scroll works fine. It's an acer laptop with a protruding scroll and not hidden within the pad like on the Dell. The only other solution is to maybe to buy a usb mouse and try that. I hoped this helped. Good luck.

Also, under most of the Dell touchpad reviews most of the people said they were not impressed with it's functionality. They also didn't like the speaker layout also. So good luck and enjoy Ubuntu 12.04 LTS. I love getting no viruses in the world of GNU/Linux, unlike Windows.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.