1

I have updated to Ubuntu 23.10 from 23.04 (Kernel from 6.2 to 6.5) and brightness control in the computer Dell OptiPlex 7780 AIO is no longer working properly.

The kernel module dell_uart_backlight (which I think is responsible of the brightness in this device) is loaded.

The brightness slider sometimes appears, and sometimes not. After locking the screen it always disappears, even if it was present before.

The command gdbus call --session --dest org.gnome.SettingsDaemon.Power --object-path /org/gnome/SettingsDaemon/Power --method org.gnome.SettingsDaemon.Power.Screen.StepUp returns:

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gsd_5fpower_5fmanager_5ferror.Code1: No usable backlight could be found!

What can I do? Thanks a lot for your help!

EDIT: If I revert to the kernel 6.2.0-35-generic the issue gets completely fixed. Shall I report this as a bug of the package linux?

Jordi.

2
  • I have the same problem as you. Please vote for bug #2032174 and bug #2049248 (sign in and select the green writing near the top). Commented Jan 14 at 16:32
  • 1
    @PaddyLandau done! Thanks. Sorry that I did not before, I was busy...
    – Txordi
    Commented Apr 17 at 11:55

2 Answers 2

0

By no means a proper fix, but I had a similar issue with GNOME (Ubuntu's default) and noticed that it disappears if I switch to its "on Xorg" version (called "Ubuntu on Xorg" in the login menu). Same behavior for GNOME classic vs GNOME classic on Xorg.

More precisely, I have a Lenovo Legion 11 with Intel processor and Nvidia graphics card; early on I realized I can only control screen brightness with the Brightness Controller app (I suspect it's partially due to me choosing Intel over AMD). After 23.10 upgrade it stopped working, and some digging made me wonder whether it's a display server protocol issue, hence trying Xorg versions of my desktop environments. Apart from different GNOME versions I also have MATE, it is not affected by the issue.

1
  • Thanks for the answer! :) Unfortunately, for me switching to X11 doesn't fix the problem... Looks to be more of a driver (kernel) issue...
    – Txordi
    Commented Nov 7, 2023 at 11:14
0

I experienced the same issue on my HP Elitebook 1080. I tried all those solutions but none worked for me. I made a bootable USB with Ubuntu 23.10. I booted in it using the option of 'Try Ubuntu or Install' In this mode, the brightness was working. I did not format or install my OS. I shut down the system and restarted without the USB stick and voila, everything was back to normal.

I would love to know if it also works for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .