I am trying to install hacketyhack software:


But i get an issue when installing thir script,

libjpeg.so.62: cannot open shared object file: No such file or directory

I checked in synaptics and it is already installed, do you have any advice?

I'm on Ubuntu 12.04.

2 Answers 2


Are you running a 64bit version of Ubuntu? If so than you need to install the 32bit version of libjpeg via this command

sudo apt-get install libjpeg62:i386

It seems hacketyhack uses the 32bit version of libjpeg

  • That worked perfectly on 64bit Linux Mint.
    – user103154
    Sep 11, 2013 at 21:13
  • 1
    For me this doesn't work (I have Ubuntu 14.04). Apt-get says: "libjpeg62:i386 is already the newest version. libjpeg62:i386 set to manually installed." When I try to locate the file I get: locate libjpeg.so.62 /usr/lib/i386-linux-gnu/libjpeg.so.62 /usr/lib/i386-linux-gnu/libjpeg.so.62.0.0 I need the file to import caffe in python. Can I somehow point python to the file?
    – mcExchange
    May 19, 2015 at 16:51
  • 1
    Worked form me w/o specifying i386 platform @ artful
    – helvete
    Feb 5, 2018 at 13:37

If the command in accepted answer doesn't work try using the following command

sudo apt-get install libjpeg62

It installs amd64 version of libjpeg62 which may be the case for some.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.