1

I tried uninstalling the snap system but it seems there's some things I wasn't aware of or understood. I tried reinstalling:

sudo snap install snap-store

2023-10-18T12:03:29-04:00 INFO Waiting for automatic snapd restart... error: cannot perform the following tasks:
- Mount snap "gtk-common-themes" (1535) (cannot proceed, expected snap "gtk-common-themes" revision 1535 to be mounted but is not)
- Mount snap "gnome-42-2204" (141) (cannot proceed, expected snap "gnome-42-2204" revision 141 to be mounted but is not)

Any ideas on how to fix this? I'd rather get everything functioning again before I decide to uninstall/remove at a later date.

Thanks.

Ubuntu 23.10.1

4
  • First, remove snap altogether, with sudo apt purge --autoremove snapd. Then, install snapd, and manually install all the snaps you need. Oct 18, 2023 at 18:10
  • And this will remove everything including these mount points?
    – vaskark
    Oct 19, 2023 at 14:22
  • Yes, it should. Let us know how it goes Oct 19, 2023 at 17:25
  • I ran the suggested command and received this: pastebin.com/jh1dmTLT
    – vaskark
    Oct 19, 2023 at 22:14

1 Answer 1

0

First run sudo systemctl stop var-snap-firefox-common-host\\x2dhunspell.mount, followed by sudo systemctl disable var-snap-firefox-common-host\\x2dhunspell.mount

Then run sudo apt purge --autoremove snapd to remove snap.

Afterwards,install snapd with

sudo apt install snapd

Then, install snap store with

sudo snap install snap-store

You will also have to manually install Firefox and other snaps.

2
  • Awesome. It worked. Thanks for all your help, Archisman.
    – vaskark
    Oct 20, 2023 at 2:48
  • @vaskark You can accept my answer by clicking on the checkmark on the left side, if it answers your question Oct 20, 2023 at 2:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .