I tried to update my system Ubuntu 12.04 64bit on amd PhenomIIx4-955BE. The power failed this afternoon, not once, but twice in a row. I knew that something was going to cause an issue. I recently resolved the dpkg issue with multiarch i386 (Unkown), I just commented it out. Now I am getting this odd error. Below is a printout of the terminal. I have had some issues with Wine before, and currently use VirtualBox. I obviously started with removing in this instance. I am a novice with linux, but can get around the cli. Please Help!

root@unimatrix725-24219:~/Documents# apt-get remove wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package wine is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.5-i386 (= 1.5.5-0ubuntu1~ppa1~precise1+pulse17) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@unimatrix725-24219:~/Documents# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  xdg-user-dirs-gtk libgvnc-1.0-dev telepathy-indicator udisks2 indicator-printers ekiga ttf-umefont
  libopal3.10.2 gedit-common gcalctool telepathy-logger lp-solve gnome-backgrounds telepathy-gabble aisleriot
  gtali glchess libpurple-dev system-config-printer-gnome hamster-applet gir1.2-gtk-vnc-2.0 gucharmap
  gnome-games link-grammar-dictionaries-en cheese libdjvulibre-dev libots0 unity-lens-video gnobots2
  gnome-disk-utility gnome-icon-theme-extras unity-scope-video-remote telepathy-haze gedit libgexiv2-1 swish++
  empathy-common libcheese-gtk21 abiword gnome-sudoku abiword-common transmission-gtk lightsoff libcheese3
  libjson-glib-dev telepathy-idle seahorse empathy libcapi20-3 libunity-misc4 libgoffice-0.8-8-common vinagre
  libtotem0 libaprutil1-ldap libopenexr-dev telepathy-salut gnibbles gnuchess-book gnome-nettool
  transmission-common shotwell libpt2.10.2 browser-plugin-gnash gir1.2-totem-1.0 gnome-games-extra-data
  libgoffice-0.8-8 abiword-plugin-grammar lib32asound2 simple-scan liblink-grammar4 wine-gecko1.5 libexif-dev
  libjasper-dev libilmbase-dev gnash-common libzbargtk0 swell-foop fonts-cantarell winetricks
  libavahi-ui-gtk3-0 libcluttergesture-0.0.2-0 liblqr-1-0-dev gnotski gir1.2-totem-plparser-1.0 libwv-1.2-4
  libgdome2-0 libaprutil1-dbd-sqlite3 gir1.2-gucharmap-2.90 libcolamd2.7.1 libclutter-imcontext-0.1-0
  cheese-common sound-juicer vino libminiupnpc8 pax libgtkmathview0c2a libtelepathy-farstream2 iagno glines
  libwmf-dev libcogl-dev abiword-plugin-mathview libmx-1.0-2 gedit-plugins gnumeric-common liferea libxdot4
  gnash gnotravex gir1.2-rsvg-2.0 gnect ps2eps ttf-unfonts-core quadrapassel libgraphviz-dev mahjongg gnumeric
  libfile-ncopy-perl gnome-games-data libudisks2-0 lib32z1 libevent-2.0-5 libmusicbrainz4-3 liferea-data
  libabiword-2.9 gnuchess fonts-droid lsb-core gnome-font-viewer ncurses-term totem-common dconf-tools
  nautilus-sendto-empathy gnumeric-doc libbz2-dev ttf-droid gnome-video-effects libgdome2-cpp-smart0c2a
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  wine1.5 wine1.5-amd64
0 upgraded, 0 newly installed, 2 to remove and 1963 not upgraded.
15 not fully installed or removed.
After this operation, 117 MB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: error: file triggers record mentions illegal package name `libgdk-pixbuf2.0-0' (for interest in file `/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders'): ambiguous package name 'libgdk-pixbuf2.0-0' with more than one installed instance
dpkg-query: error: file triggers record mentions illegal package name `libgdk-pixbuf2.0-0' (for interest in file `/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders'): ambiguous package name 'libgdk-pixbuf2.0-0' with more than one installed instance
debsums: dpkg-query --admindir=/var/lib/dpkg --showformat=${Package}







 --show failed (exit status 2)
E: Problem executing scripts DPkg::Post-Invoke 'if [ -x /usr/bin/debsums ]; then /usr/bin/debsums --generate=nocheck -sp /var/cache/apt/archives; fi'
E: Sub-process returned an error code
E: Sub-process /usr/bin/dpkg returned an error code (2)

When I try dpkg --remove libgdk-pixbuf2.0-0, I get:

# dpkg --remove libgdk-pixbuf2.0-0 
dpkg: error: file triggers record mentions illegal package name libgdk-pixbuf2.0-0' (for interest in file /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders'): 
ambiguous package name 'libgdk-pixbuf2.0-0' with more than one installed instance

1 Answer 1


Try this:

sudo apt-get remove --purge libgdk-pixbuf2.0-0:i386
sudo apt-get -f install


sudo apt-get remove --purge libgdk-pixbuf2.0-0:amd64
sudo apt-get -f install


sudo apt-get remove --purge libgdk-pixbuf2.0-0*
sudo apt-get -f install

It seems you have both the 32-bit (i386) and 64-bit (amd64) version of libgdk-pixbuf2.0-0 installed, and this is what it is complaining about. The first command will remove the 32-bit version. You appear to be mixing up 32-bit and 64-bit on your wine install too. You should always use 64-bit packages on a 64-bit system.

Also, on a side note, you shouldn't use sudo su to login as root, unless you have a specific reason. You should always just preface your commands that need administrative privileges with sudo, as it is much more secure this way.

  • Here is what I have now. Thank you for the tips, very appreciated. Thank you for your time too...Is there a script that you know of that will strip my system of all uneeded code arch code? I knew of a similiar function for Mac OS X....?unimatrix725@unimatrix725-24219:~/Documents$ sudo apt-get remove --purge libgdk-pixbuf2.0-0:i386Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package libgdk-pixbuf2.0-0:i386 E: Couldn't find any package by regex 'libgdk-pixbuf2.0-0' unimatrix725@unimatrix725-24219:~/Documents$
    – Jesse
    Jun 12, 2012 at 15:03
  • No problem. I don't know of a command to do that, although that doesn't mean it doesn't exist. The issue would only pop up from adding incorrect PPAs, so check to make sure those are all using amd64. Also, I updated the answer with a couple other things to try.
    – reverendj1
    Jun 12, 2012 at 15:18
  • I tried both commands above. They fail either way. I am rather frustrated with this. I am not sure why synaptic manager or smart package manager defaults to selecting i386 on a x64 system. I assume it is because of the dependancies listed, so does this make it the "packagers fault"? Here is the output -pastie.org/4094073
    – Jesse
    Jun 15, 2012 at 19:19
  • It looks like you successfully removed libgdk-pixbuf2.0-0, as it is now complaining that it isn't installed. So what happens when you run sudo apt-get -f install now?
    – reverendj1
    Jun 15, 2012 at 19:29
  • Also, paste.ubuntu.com is the preferred Pastebin,to use, as it is hosted by Ubuntu, so our answers don't depend on external websites. i.e. if they go down, so does the info.
    – reverendj1
    Jun 15, 2012 at 19:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .