0

I was trying to unbind the default keyboard shortcut Alt+Ctrl+Shift+Down (to use it to copy a row down in vscode instead).

The best way I found in order to find out which action is using a specific shortcut is to try to add it to a "Disabled" shortcut in the "View and Customize Shortcuts" under Keyboard preferences. When I do it says this particular one is used by "Move window one workspace down". I can't find this binding anywhere when clicking around and not by searching.

When looking around in the workspaces settings, it seems that there is no "down" concept anymore but instead a slider that only have workspaces horizontally. Maybe this shortcut is still there behind the scenes but still active?

This is also weird, but unrelated:

  1. Go to "Keyboard Shortcuts"
  2. Click "Custom Shortcuts"
  3. Click the arrow top left to go back.
  4. Click on any of the categories that contain standard shortcuts.
  5. They are now empty.

Versions: Ubuntu 23.04 Gnome 44.3 on Wayland

1 Answer 1

0

You discovered that the "Keyboards Shortcuts" dialog in settings is limited.

  1. It does not expose all possible keyboard bindings
  2. It does not allow to assign or change multiple keyboard bindings assigned to the same function.

While vertical workspaces are gone, the shortcut key is still assigned by default. This is actually a little oversight from the developers.

To see all possible settings, including keyboard bindings that are not exposed in the GUI, you can use dconf-editor. The key you want to disable is for the setting move-to-workspace-down, which you find navigating as org/gnome/desktop/wm/keybindings. There, edit the setting move-to-workspace-down by clearing the existing entry '<Control><Shift><Alt>Down']. (you may also leave '' there.)

dconf-editor can be searched for settings, but using the terminal may sometimes allow for a more powerful search. The command gsettings list-recursively will list all possible settings. You can search these using grep, e.g. as in

gsettings list-recursively | grep -i "workspace" | grep -i "down"
1
  • Thank you, that solved it. Not sure exactly where to look to report an official bug. My guess is that this is already a known issue though.
    – miccet
    Oct 4, 2023 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .