I bought an AZTECH WL562USB wireless adapter and am stuck trying to install the driver.

The driver file I downloaded is a BZ2, called


How can I install the driver from this bz2 file?


I found this workaround that worked for me:

This is how I got my RT5370 usb wifi adapter installed and working on CB2.

  1. download driver archive

    2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2 .5.0.3_DPO.bz2 (RT8070/RT3070/RT3370/RT5370/RT5372 USB 03/28/2012

  2. unpack the archive and navigate into the top level directory just extracted:

    tar jxvf  2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO.bz2
    cd 2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO
  3. modify the following code in os/linux/config.mk as below:

  4. to quieten down the debugging modify sta/sta-cfg.c:

    remove "#ifdef DBG" on line 4095
    remove "endif /* DBG */" on line 4693
  5. to change the name from ra0 to wlan0 modify include/rtmp_def.h and change ra to wlan in the following lines:

    #define INF_MAIN_DEV_NAME        "ra"
    #define INF_MBSSID_DEV_NAME        "ra"
  6. make and install the modified driver

    sudo make install
    sudo modprobe rt5370sta
  7. reboot and check with lsusb lsmod and ifconfig to make sure all is working as required in the operating system.

The CB2 setup program didn't work for me but the xbmc network manager addon worked perfectly so I downloaded and use that rather than doing it all via the operating system.

I hope this helps someone else trying to get an RT5370 wifi adapter up and running.


  • 1
    This solution probably worked in Linux 2.x, but it fails to compile in Linux 4.15 (Ubuntu 18.04). The source code in the linked archive is outdated.
    – naXa
    Jun 21 '18 at 19:45

How to download, build and install the RT3070 driver

  • Your adapter has a Ralink RT3070 chipset. You can download the official Linux drivers from this site.

  • We'll suppose the driver has been downloaded to your Downloads folder and is called 2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO.bz2. Open a terminal with Ctrl-Alt-T, and type or paste the following:

    sudo apt-get install linux-headers-$(uname -r) build-essential
    cd Downloads
    tar -xjf 2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO
    cd 2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO
    sudo make && sudo make install
    make clean
    cd ..
    rm -rf 2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO
  • Reboot, and hopefully your wireless connection will appear!

  • @user69589 Alternatively you can download the driver direct from the manufacturer of your card here which you can install following the above steps. Jun 10 '12 at 3:52
  • @MarkRooney That's an older driver.
    – ish
    Jun 10 '12 at 3:55
  • You have a dead link. Nevertheless, you can download the driver file from my repo here now: 2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO.bz2. Sep 28 '20 at 8:14
  • When I run sudo make I get this error: make[2]: *** No rule to make target 'arch/x86/tools/relocs_32.c', needed by 'arch/x86/tools/relocs_32.o'. Stop. make[1]: *** [arch/x86/Makefile:232: archscripts] Error 2 Sep 28 '20 at 8:22
  • Same as Gabriel Staples: I get the same error.
    – th3pr0ph3t
    Dec 3 '20 at 4:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.