Since I installed Ubuntu 12.04, Rhythmbox, Banshee and Sound Juicer have started acting weird around double cd's, and specifically, cd #2 of said double cd.

  • Sometimes, they will show the information of cd #1. Track names, durations, and even count are incorrect.
  • Sometimes, they will first show the tracks for cd #1, then continue onto cd #2 if cd #2 has more tracks than #1.
  • Sound Juicer seems to be unable to find any track durations at all, even for single cd's.

Obviously, this is a pain when I'm trying to rip double cd's. And I have a fair number of them, which I want to rip.

This happens on both my machines (a slightly aging iMac, and a 1-year-old Sony Vaio). However, on previous versions of Ubuntu, this never happened. All on the same machines. So I suspect 12.04 is using a different lib for extracting audio cd data. Just for kicks, I tried with Linux Mint 13, and there it works correctly, even though it claims to be based on Ubuntu 12.04 and therefore should be using (partially) the same software. So if the Mint guys can fix it, I should be able to do it too, right?

So, my question: what changed in 12.04 that could cause this? And more importantly: what can I do to fix it?

UPDATE Installed versions of relevant software packages, according to Synaptic:

  • libmusicbrainz3-6: 3.0.2-2.1
  • libmusicbrainz4-3: 4.0.0-0ubuntu1
  • sound-juicer: 3.4.0-1ubuntu1
  • rhythmbox: 2.96-0ubuntu4
  • You may not have installed libmusicbrainz4 at all, or a previous version. – jasmines Jun 12 '12 at 17:32
  • @jasmines How do you mean? Is libmusicbrainz4 somehow different from libmusicbrainz4-3? Also, according to Synaptic, these are all the most up-to-date versions. – jqno Jun 13 '12 at 6:39
  • @jasmines As you can see, yes. But again, this is a clean install of Ubuntu. In fact, it's been several clean installs on two different machines. I've had this problem on each and every one of them. – jqno Jun 13 '12 at 7:26
  • Check if this work: sudo add-apt-repository ppa:phw/musicbrainz (press enter) sudo apt-get update && sudo apt-get upgrade (press enter) – jasmines Jun 13 '12 at 7:35
  • @jasmines Nope, sadly, this doesn't help either... Doesn't seem to have changed the versions of libmusicbrainz either, – jqno Jun 13 '12 at 19:45

Fwiw, I was annoyed by the same problem, and others... Sound Juicer is a decent entry-level ripper but has lots of issues like this which have remained unfixed for a very long time.

My own solution was to switch to a command line CD ripper, abcde. You set up an ~/.abcde.conf file with your preferences for what encoder to use, how to name files, and so on. It seems to do a much better job of looking up track listings, and even fills in Genre, which I always had to do manually with Sound Juicer. In my experience of about 40 cd rips so far the track listings are 99% proper, and it lets you edit in a terminal editor to get that last 1% correct.

So, it's a bit more technical than a GUI ripper but much more flexible and IMHO less buggy. I tested it out on a couple double-cd albums and it worked great.

This is the tutorial I used; he gives several sample config files for different common cases: http://www.andrews-corner.org/abcde.html

Pretty much I just went with the mp3 example he listed. My only significant change was I wanted my music files to be all lowercase with no spaces or special characters, so redid the mungefilename() function like this:

mungefilename ()
  echo "$@" | sed s,:,-,g | tr / _ | tr -d \'\"\?\[:cntrl:\]\(\)\* \
       | sed s,\ ,_,g | tr [:upper:] [:lower:]

But the one in that example is perfectly serviceable.

  • Thanks, good suggestion! It has a lot of options though. Could you maybe post your conf file and your command line, so I have something to work from? – jqno Jun 16 '12 at 6:53
  • Sure, actually I'll point to the tutorial I found useful. – Bryce Jun 16 '12 at 23:58
  • Awesome! Not quite what I had in mind when I asked the question, but very useful. Thanks. I'll give you the bounty :). – jqno Jun 17 '12 at 11:43

Answering my own question:

The Asunder CD Ripper (available through the Software Center) solves the problem.

It doesn't use MusicBrainz, so I'm guessing that that is the culprit. This bugreport seems to back up that hypothesis.

I'm not super happy with this solution (Asunder doesn't support a lot of metadata fields and besides, I'd much rather rip my cds through Rhythmbox), so I'm not accepting this answer just yet. But I thought I'd mention this for other people who might have the same problem.

  • if you simulate an uninstall of libmusicbrainz3-6 what does it suggest that it will uninstall? sudo apt-get -s purge libmusicbrainz3-6 – fossfreedom Jun 14 '12 at 21:00
  • @fossfreedom The only package it will uninstall is sound-juicer. If I do the same thing for libmusicbrainz4-3: lots of packages related to rhythmbox. – jqno Jun 15 '12 at 6:38
  • you are therefore on the right track - sound juicer is currently linked to the older musicbrainz library that has the issue in the bug-report. Either you need to find a newer version of sound-juicer that is compiled against brainz v4 or investigate whether soft-linking the libmusicbrainz3-6 library (its .so file) to the v4 library (.so) will be enough to fool sound-juicer (doubtful this will work though). – fossfreedom Jun 15 '12 at 8:21
  • @fossfreedom Yes, but the reason I installed sound-juicer in the first place, was because I ran into this issue in Rhythmbox (which uses libmusicbrainz4-3) :). – jqno Jun 15 '12 at 9:16

Known issue: http://tickets.musicbrainz.org/browse/MBS-2693

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.