I can't update my system because it freezes while installing a third-party update (zramswap-enabler)!

Sometimes I get the following message in Update manager:

Could not initialize the package information An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

E:The package zramswap-enabler needs to be reinstalled, but I can't find an archive for it.

I tried to remove the zramswap-enabler, but it's impossible because I get the following message:

dpkg: error processing zramswap-enabler (--remove):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Actually I would really reinstall that package, but it is unable to do it! If I remove this third-party PPA then the system is warning me about a very very serious problem.

So why can I not install/reinstall/remove/update this package and why freezes the updater if I try to update?


8 Answers 8


Edited out of the question and added as an answer.

  1. Make sure that your PPA is set up.

  2. Remove the broken package via the following command:

    sudo dpkg --remove --force-remove-reinstreq zramswap-enabler
  3. Install the package again:

    sudo apt-get install zramswap-enabler
  4. After restart (not necessary), you are able to install the updates correctly!

Actually you can fix any "Package is in a very bad inconsistent state” issues with this solution!

  • 1
    @CharlesL Not a problem! Note that this answer is community wiki, and the solution was initially found by the author of the question, so I can't take credit for it. All I did was edit and reorganize to move it into an answer.
    – nanofarad
    Commented Dec 6, 2015 at 13:28
  • I had some trouble with this one (14.04 to 16.04). "gcc-doc" didn't work. The error message showed /var/cache/apt/archives/gcc-doc_4%3a5.3.1-1ubuntu1_amd64.deb, and the tools reject '%' in the name, so the full name didn't work either. I ended up removing files until it was happy -- see ubuntuforums.org/showthread.php?t=2321414&page=2 .
    – fadden
    Commented Nov 27, 2016 at 16:20
  • 4
    I had to use a combination of --force-remove-reinstreq and --purge --force-depends when cpp-5 somehow had broken dependency problems.
    – dashesy
    Commented Jan 5, 2017 at 21:53
  • This didn't work for me, add autoremove and autoclean from Hamman's answer! Commented Aug 9, 2020 at 23:46
  • @Luka this post is a few years old now and is community wiki meaning that you should be able to edit it directly (the rep requirement is far lower)
    – nanofarad
    Commented Aug 10, 2020 at 0:03

This worked for me after pretty much scouring the whole of AskUbuntu and Ubuntu forums! (Source). I'm running Lubuntu 14.04

sudo mv /var/lib/dpkg/info/<packagename>.* /tmp/
sudo dpkg --remove --force-remove-reinstreq <packagename>
sudo apt-get remove <packagename>
sudo apt-get autoremove && sudo apt-get autoclean
  • 3
    Finally! This did the trick when dpkg and apt won't remove or reinstall a package
    – abaelter
    Commented Mar 12, 2015 at 7:51
  • 1
    Thanks. This saved me BIG TIME! I tried skipping the last line, followed by a apt-get install... and had to start over and do ALL four lines, then I could finally purge my package. :)
    – Ryan H.
    Commented May 1, 2015 at 7:43
  • 1
    The only true answer which works any time.
    – twicejr
    Commented May 20, 2016 at 12:26
  • 1
    This helped when I had problems with gcc-doc and cpp-doc after an upgrade from 14.04. I had more recent tools install from ppa:ubuntu-toolchain-r/test and they screwed everything up. Moral of the story, purge ppas before upgrading to a new release. But this tip helped me in fixing the mess afterwards.
    – Charphacy
    Commented Aug 3, 2017 at 0:39
  • 3
    I have done the following but got an error: sudo mv /var/lib/dpkg/info/libgcc1:i386.* /tmp/ sudo dpkg --remove --force-remove-reinstreq libgcc1:i386 dpkg: dependency problems prevent removal of libgcc1:i386: libc6:i386 depends on libgcc1. dpkg: error processing package libgcc1:i386 (--remove): dependency problems - not removing Errors were encountered while processing: libgcc1:i386 Commented Aug 28, 2017 at 5:22

I had a situation worse than this. I had to remove the half-installed packages by forcing dependencies.

sudo dpkg --remove --force-remove-reinstreq --force-depends <package-name>

Then I had to reinstall them

sudo apt-get -f install

That should solve any issue. But please make sure you have network connectivity when you try to do this. Otherwise, you will have to go through even more trouble.

  • 1
    I get an error: dpkg: error processing package debconf (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Errors were encountered while processing: debconf Commented Jan 30, 2017 at 21:34

The other answers are correct to mention a package removal followed by apt-get install -f to reinstall the broken package (and fully install other half-installed packages). However, this can be done in one step:

sudo apt-get install -f --reinstall zramswap-enabler

i'd try cleaning the status of my installation before resorting to uninstalling whatever created the problem:

apt-get autoclean
apt-get update
apt-get upgrade
apt-get install -f

much better way to solve this in most cases and in at least one instance had helped me when the other way wouldn't work (because huge dependencies on the package to be removed)

  • This yields an error: sh: 0: getcwd() failed: No such file or directory /bin/sh: 1: /usr/sbin/dpkg-preconfigure: Permission denied Commented Jan 30, 2017 at 21:36
  • 1
    I'd guess you did this from an non-admin account. Try prefixing each line with sudo or completely login as root (i.e. with: "sudo su" and your password or "su" and the admin-password) Commented Feb 1, 2017 at 8:57

I had similar problem with quagga, the routing daemon. Just reinstaling the package worked for me:

# apt-get install -f  
<some output ommited>
dpkg: warning: overriding problem because --force enabled:
Package is in a very bad inconsistent state - you should
reinstall it before attempting a removal.

wget http://security.debian.org/debian-security/pool/updates/main/q/quagga/quagga_0.99.22.4-1+wheezy3_i386.deb
dpkg -i quagga_0.99.22.4-1+wheezy3_i386.deb

Now its ok again:

#apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

The same thing happened to me when I got disconnected from the internet while downloading the wireshark package. After that, when I tried to reinstall it, it threw the same error:

Package is in a very bad inconsistent state

I've tried all the commands to install, purge, remove and reinstall but nothing worked.

After a little bit of googling, I stumbled upon this command:

sudo dpkg -i --force-overwrite /var/cache/apt/archives/libwireshark8_2.2.6+g32dac6a-2ubuntu0.16.04_amd64.deb

(changed libwireshark8_2.2.6+g32dac6a-2ubuntu0.16.04_amd64.deb with the package that was creating the problem in the directory /var/cache/apt/archives/).

After running this command all the issues were resolved. I removed the package again using:

sudo apt --purge remove libwireshark8:amd64
sudo apt autoremove to fully remove the package.

Then I installed wireshark again using:

sudo apt-get install wireshark

Everything works smoothly now!



I used this to fix this same issue:

apt reinstall [package] 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .