I just recently bought a HP DV6T-7000 Quad Edition. It has an Intel HD 4000 and a Nvidia GeForce GT 650M 2GB with Optimus. I read that I could use bumblebee to make optimus work, so I installed it. I also installed bumblebee-nvidia and nvidia-current from the ubuntu-x-swat/x-updates ppa. I rebooted, but when I tried to run anything with optirun, the computer would wait ten seconds or so, then do a hard shutdown. I got no log messages from bumblebee, Xorg, or optirun, either. I have purged and reinstalled bumblebee, bumblebee-nvidia, and nvidia-current. I have also turned off power management for nvidia in the bumblebee.conf file to no avail. I am out of ideas about this, and I need both graphics options. Any ideas would be much appreciated.

UPDATE: Today (6/14/12), I updated my kernel (to version 3.2.0-25) and reinstalled bumblebee-nvidia and nvidia-current (from ppa:upubuntu-com/nvidia with driver version 295.59) so the new driver would build against the new kernel. I noticed several things:

  1. Optirun worked (with various errors).
  2. I had to modprobe nvidia-current and modprobe -r nvidia-current before I got optirun to stop telling me that the card fell off the bus.
  3. Once I did that, I was able to run non-OpenGL applications with optirun; however, running OpenGL applications would give me the error Xlib: extension "GLX" missing on display ":8".
  4. Looking this up quickly yielded the following page: https://github.com/Bumblebee-Project/Bumblebee/wiki/Troubleshooting which listed my issue. Following the instructions in the section resulted in my having the same issue (shutdowns) that I posted about originally.

I also found this article, where someone said in the comments that he experienced the same issue if he did not run a cuda program before running optirun. (comment number 9). I will try this and see if it works, if it does maybe I can add a quick cuda program to my init scripts?

Thanks to everyone who already replied, I really appreciate your help.


Today (6/23/12), I switched to the xorg-edgers ppa to see if the newer drivers/xorg/etc would fix my problem. Now I'm getting the same errors listed above in numbers 1, 2, and 3. I have not tried step 4 yet because I do not want to wreck something up like I did last time (at least now non-gl applications run).

Also, CUDA is getting me nowhere due to make errors, so for now, that's out of the question.


4 Answers 4


I had the same problem and this solution helped me resolve it.

In /etc/bumblebee/xorg.conf.nvidia I put the line with ConnectedMonitor and instead added Option "UseDisplayDevice" "none".


it doesn't work because support for our cards is only available in the latest driver released yesterday. Everything up to this point only breaks your machine. Also wouldn't recommend purging nvidia-* like the previous user has stated that will remove ubuntu-desktop as well causing more issues.

Version:295.59 Certified
Release Date:2012.06.11
Operating System:Linux 64-bit
Language:English (U.S.)
File Size:55.8 MB

Added support for the following GPUs:

NVS 5400M
NVS 310
GeForce GT 620M
GeForce GT 640M
GeForce GT 640M LE
GeForce GT 650M
GeForce GTX 660M
GeForce GTX 670M
GeForce GTX 675M
GeForce GTX 555
GeForce GTX 560 SE
GeForce GT 415
GeForce GTX 460 v2

Disabled the use of certain OpenGL optimizations with Autodesk Maya and Mudbox, due to conflicts between these applications and the optimizations. Some performance loss in Autodesk Maya and Mudbox is possible, as a result. Fixed a behavior issue where redundant DPMS state transitions were leading to unexpected screen blanking on DisplayPort displays.

  • I'm still getting the same issue, unfortunately. Tell me if I did something wrong. Here are the steps I took: 1. purged bumblebee-nvidia and nvidia-current 2. added the following ppa: ppa:upubuntu-com/nvidia and updated my package lists 3. Installed bumblebee-nvidia (which I saw pull in the new driver) 4. rebooted my machine.
    – user69469
    Jun 13, 2012 at 20:43

According to the official bumblebee-project page, you have to undertake the following installation steps in Ubuntu:

1) open terminal window and type in

sudo add-apt-repository ppa:bumblebee/stable

If you are on Ubuntu 11.04 or older and want newer drivers (recommended) than the ones available in the official repos, run:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update

2) To install Bumblebee using the proprietary nvidia driver:

sudo apt-get install bumblebee bumblebee-nvidia

3) Reboot or re-login.

As you can see, installing nvidia-current is not required. Following these steps exactly, bumblebee installs the current nvidia drivers with the bumblebee-nvidia package. So solve your problem, undo all customizations and purge the nvidia-* packages (though, a clean install of ubuntu is recommended) and follow the instructions above strictly. I hope this helps.

  • I've done all of that several times, purging in between.
    – user69469
    Jun 10, 2012 at 23:45
  • As you wrote before, you seem to additionally install the nvidia-current package too. This is what you SHOULD NOT do because installing this package additionally causes issues like yours. I know because I also made the same mistake when I installed bumblebee the first time.
    – MrMuretto
    Jun 10, 2012 at 23:50
  • 1
    nvidia-current is installed as a dependency by bumblebee-nvidia.
    – user69469
    Jun 11, 2012 at 0:22
  • Also, just for good measure, I purged bumblebee, bumblebee-nvidia, and nvidia-current and followed the above instructions word for word. After rebooting I got the same result as in my original question when I executed "optirun glxgears"
    – user69469
    Jun 11, 2012 at 0:41

It's a bug. I see it, too, although updating the driver didn't help me. I've opened issue 203 to track it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .