0

I have Ubuntu 22.04 and a VPN that allows me to work within the servers of the company I work for. Everything worked well until today.

Now, when I try to connect, it says "Authentication failed" in a popup message. When I check out the /var/log/syslog I can see that the problem is at a line that says:

pppd[6130]: MS-CHAP authentication failed: 

Note that there are no details after "authentication failed: ". In other troubleshootings I found on the internet, there were at least some credentials reported.

I have not changed my credentials, I have not changed any setting of the VPN, and it worked well for weeks before today.

I have tried to follow this but it didn't work for me: L2TP / IPSec failing to connect (Kubuntu 17.10)

I followed this one too, and it did not solve the issue: 22.04 l2tp client not working

I then followed the advice provided by punisher_man in this conversation: https://www.reddit.com/r/Ubuntu/comments/u8uwzv/ubuntu_2204_lts_vpn_l2tp_stops_working/?rdt=47816

Sadly, nothing seems to fix this issue. I have run out of ideas and I don't know how to move forward. Any suggestions?

4
  • When you "try something" suggested by some Internet Rando, and find that it "doesn't work", do you undo the changes you made? Or do you pile change upon change upon ... ?
    – waltinator
    Sep 18, 2023 at 22:49
  • Yes, I take care of that. But I really didn't know where to look so I tried different things and checked what happened in the syslog.
    – schmat_90
    Sep 19, 2023 at 8:22
  • Is it pptp vpn? Is it configured using network manager? Has anything else - such as possibly your password changed?
    – vidarlo
    Sep 19, 2023 at 9:26
  • It's L2TP and they made me configure it that way on my first day. It worked fine, then I was on vacation for two other weeks recently and on my day back it wasn't. Password and protocol are correct for sure, it was my first thought indeed.
    – schmat_90
    Sep 20, 2023 at 5:20

0

You must log in to answer this question.

Browse other questions tagged .