1

I am a newbie Kubuntu 22.04 x64 user. I have kernel version: Linux 6.2.0-31-generic x86_64.

I have 2 houses, and i installed on both PCs the same OS version (same ISO): a) PC Desktop + NAS running with SMB1 (Buffalo Linkstation). b) notebook + another NAS with SMB1 (another Buffalo Linkstation, but older model than location above)

From command line, i need to connect to NAS shares.

In location "a", after some tris i finally can connect to my share with this command:

sudo mount -t cifs //192.168.2.6/development /nas/development -o username=wout,password=xxxxxxxx,domain=MSHOME,vers=1.0 

and i can connect without problems. (Next step will be use a credentials file instead of user/pass in command)

In location "b", with older NAS, using smb4K i can connect to my nas using Dolphin, but i really can't find how to make the command above to work. It's been one week I am hammering my head on this notebook, but any result.

sudo mount -t cifs //192.168.2.6/development /nas/development -o username=wout,password=xxxxxxxx,domain=MSHOME,vers=1.0 

Has result:

mount.cifs kernel mount options: ip=192.168.2.6,unc=\\192.168.2.6\development,vers=1.0,user=wout,domain=MSHOME,pass=******** mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

This is the output of: tail -f /var/log/kern.log :

Sep  3 15:42:40 wout kernel: [ 2807.010994] CIFS: VFS: Use of the less secure dialect vers=1.0 is not recommended unless required for access to very old servers

Sep  3 15:42:40 wout kernel: [ 2807.011003] CIFS: Attempting to mount \\192.168.2.6\sviluppo

Sep  3 15:42:40 wout kernel: [ 2807.034540] CIFS: VFS: cifs_mount failed w/return code = -22

I tried to modify /etc/samba/smb.conf

   workgroup = MSHOME
   min protocol = CORE
   client min protocol = NT1
   server min protocol = NT1

But any result: Dolphin works fine, but from command line I can't connect and the kernel.log isn't helping too much as it does not write which argument is wrong.

I tried to change position of arguments, mount folder, nas path,.. nothing

I tried the command modprobe cifs disable_legacy_dialects=n

Is there anyone who can kindly help me giving some advices, please?

I red almost every post about this problem but i can't find a solution, maybe there is something missing in my installation

1 Answer 1

2

In location "b", with older NAS, using smb4K i can connect to my nas using Dolphin, but i really can't find how to make the command above to work. It's been one week I am hammering my head on this notebook, but any result.

sudo mount -t cifs //192.168.2.6/development /nas/development -o username=wout,password=xxxxxxxx,domain=MSHOME,vers=1.0

Add another option to your mount declatation: nodfs

sudo mount -t cifs //192.168.2.6/development /nas/development -o username=wout,password=xxxxxxxx,domain=MSHOME,vers=1.0,nodfs

Better?

1
  • Thank you very much @Morbius1, it works! Reading what this parameter stands for, I really couldn't think that this would be the solution. You are very good! Commented Sep 5, 2023 at 14:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .