Possible Duplicate:
Does 12.04 need graphics drivers for NVidia?

I have an old system which is not connected to internet. The computer specification as below,

Now if you see the specification of mobo, you can see the chipset is NVIDIA GeForce 7050/nForce 610i and VGA card is Integrated GeForce 7050 GPU.

I used to run ubuntu 11.10 on that system and install drivers from Addtional drivers.

Now gave the desktop to my sister, and installed ubuntu 12.04 from a image created by remastersys.

I removed all unnecessary softwares, drivers after installation. It is now working fine.Unity 3D is running but very slow. So I think I need to install the additional driver.

As I told earlier, it is not connected to Internet. Only thing I can do to download the package from another system and install it there. But I couldn't determine which package needs to be downloaded.

| improve this question | | | | |

Your graphics card is not supported with the latest version of the Nvidia drivers, you need to install the legacy drivers called nvidia-173 from the restricted repository.

To get a list of packages and dependencies necessary to install the drivers you can use this command to get that list saved to a .txtfile (source), don't worry, it will not install naything in your system:

sudo apt-get --print-uris --yes --reinstall install nvidia-173 | grep ^\' | cut -d\' -f2 > nvidia-173.txt

After you have the list and checked the .txt file you can then download the packages with wget or any other downloader tool of your choice:

wget --input-file nvidia-173.txt

this will read each line in the nvidia-173.txt file and download it to you current directory.

After you saved the files in a USB drive or any other removable media you can then just go to your other computer, change directory to where you saved the files and use sudo dpkg -i *.deb to install them.

| improve this answer | | | | |
  • receiving this error - E: Unable to correct problems, you have held broken packages. – Web-E Jun 9 '12 at 7:54
  • Use sudo apt-get --print-uris --yes --reinstall install nvidia-173 in a terminal and check for errors, post them if you find anything relevant. – Bruno Pereira Jun 9 '12 at 7:56
  • Getting this message nvidia-173 : Depends: xorg-video-abi-10 but it is not installable . i tried in one virtual machine also. Same error. However I will try with the package in nvidia site. Will let you know. – Web-E Jun 9 '12 at 8:45
  • @Web-E :/ I have been checking and seems like the package is broken for 12.04. I will update this asap. – Bruno Pereira Jun 9 '12 at 13:41
  • I have an even older graphics chipset (NForce4) and as far as I can work out, I need the nvidia-96 package. When I use the above commands but modified for nvidia-96, I get the same errors so fingers crossed, once the package is fixed, it may well work for me too! – PhillC Jun 15 '12 at 15:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.