24

I need to enter the command line alone with no GUI to install the official NVIDIA drivers. I'm trying to get my computer to work over HDMI and someone on Youtube shows how but you have to be in the Nvidia settings program.

0

7 Answers 7

27

To do that just follow this:

  1. Go to CLI mode:

    CTRL + ALT + F1

  2. Stop GUI service on Ubuntu:

    sudo service lightdm stop
    

    or if you're using a version of Ubuntu before 11.10, run:

    sudo service gdm stop
    
3
  • 2
    Perhaps add more Display managers, for the other variants of Ubuntu. Jun 9, 2012 at 16:25
  • 2
    running this from terminal sudo service lightdm stop worked for me.
    – razzak
    Dec 8, 2015 at 11:53
  • 2
    This simple service stopping and starting works - but it is the full canonical mode change? In the old times one entered non-graphical mulit-user mode by 'runlevel 3' and back graphical by 'runlevel 5'. With systemd this should translate to (A) systemctl isolate multi-user and (B) systemctl isolate graphical. (A) indeed closes GUI, (B) brings up the login screen again - which however yields errors ("Could not connect to bus session: Failed to connect to socket /run/user/1000/bus: Connection refused") when trying to login. Why?
    – kxr
    Apr 29, 2019 at 20:14
14

Use

sudo service gdm stop

to stop the GUI and

sudo service gdm start

to start it again

3
  • 2
    If you use kubuntu change gdm with kdm :)
    – kv1dr
    May 31, 2011 at 12:09
  • I'll accept yours because my question was too way specific. Actually I needed to run telinit 1 to completely disable not required processes.
    – dierre
    May 31, 2011 at 12:11
  • With Ubuntu 18.04 this turns it off but doesn't turn it back on...any ideas? Apr 18, 2021 at 10:08
7

If your purpose is to temporarily disable GUI - you can stop the lightdm service ( or whichever greeter you're using ) with sudo service lightdm stop (14.04 and earlier) or sudo systemctl stop lightdm (since 15.04) from tty1, as shown by others already.

If your purpose to boot into command line for extended period of time between reboots, you can open /etc/default/grub with the choice of your text editor. I personally use nano, so for me the command would be sudo nano /etc/default/grub. Now, find GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="text". Or you can create two lines, one commented , one uncommented like so:

#GRUB_CMDLINE_LINUX="text"
GRUB_CMDLINE_LINUX=""

Once necessary, just uncomment the line for which mode you wanna enter. Upon completing editing the /etc/default/grub file, save it, and run sudo update-grub to make the configurations loaded into the actual grub.cfg file. Reboot, and you should enter the command line directly.

2

Start by logging out and striking CtrlAltF1, then log on.

On Kubuntu stopping the GUI can be done through sudo /etc/init.d/kdm stop. On Ubuntu this will probably be sudo /etc/init.d/gdm stop.

Enter your password when prompted.

dm stands for Display Manager, check ls /etc/init.d/ which dm is available when it is not gdm.

To restart it just change stop to start.

You probably automatically change to the GUI, if not strike: CtrlAltF7

1
  • obysr's lightdm sounds familiar. That would make the command: sudo /etc/init.d/lightdm stop
    – jippie
    Jun 9, 2012 at 7:15
1

I know you are not asking this specifically, but you need to install the nvidia-current driver.

You can do this from a gui. Just run jockey-gtk or search for "Additional Drivers" from the dash. Once it is installed, open Nvidia Settings and go from there.

0

You could open gnome-terminal and type sudo telinit 1. This would drop you to run level 1(single user mode) and kill the gui services.

7
  • it's not happening. I typed sudo init 3 but nothing changed.
    – dierre
    May 31, 2011 at 11:53
  • it was sudo telinit 1, then choose root.
    – dierre
    May 31, 2011 at 12:08
  • @bertmanphx: you are not aware of ubuntu startup process and runlevels used.
    – enzotib
    May 31, 2011 at 12:36
  • @dierre: I think it is not correct to edit answers in the core, like changing 3 to 1. This invalidates OP intentions and my objection.
    – enzotib
    May 31, 2011 at 12:42
  • 2
    Well the answer was actually useful so I thought to correct the wrong parts.
    – dierre
    May 31, 2011 at 12:43
0

to stop GUI from auto-loading

sudo systemctl set-default graphical

to start it again:

sudo systemctl set-default graphical

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.