I can see and connect to Ubuntu box from Windows 7 Laptop, but the Ubuntu box keeps telling me failed to retriever share list from server.

The laptop shows up in the list of computers in the workgroup but even when connecting by using the IP address, I get an error cannot display location "smb://xxx.xxx.x.xx and Failed to retrieve share list from server ......

Pleas advise what could be wrong. Ubuntu box is running a 32 bit version of the OS whereas the Windows 7 laptop is running an X64 version of Win7 & Ult.

  • Same problem, for reference this is what I have unsucsessfully tried to solve it: Various login combinations (username, administrator, WOKGROUP, MACHINENAME), disable homegroup sharing (leave simple smb enabled), enable passwordless sharing, create a new user to own the share. None worked, always get a password prompt, and always fail. – Jeremy Nov 25 '10 at 2:26
  • There have been a few of these windows/linux sharing threads, the concensus seems to be that it's fairly broken, which seems hard to beilive. – Jeremy Nov 25 '10 at 2:31

Please see this post

Nautilus wants a password when I try connecting to a public Windows share

It mentions setting up a speific "guest" permission on the share. I'll give it a shot and let you know how it went, but the OP from that thread has accepted the answer.

  • Well, didn't work for me, hope you have better luck. – Jeremy Nov 25 '10 at 3:01

I've heard a lot of people are having troubles with win7 and it's samba shares (even other versions of windows). Try to make sure the settings for sharing is set to the most compatible (and least secure) on win7. As far as I remember, they've added some stronger encryptions, that might not be backwards compatible.

  • I think the "most compatible and least secure" is turning off homegroup and enabling passwordless sharing. This didn't work for me, but give it a whirl. To get to the settings: Network and Sharing Centre -> Choose Homegroup an Sharing Options -> Leave Homegroup, then Change Advanced Sharing Settings... – Jeremy Nov 25 '10 at 2:29

11.04 (Natty) & Windows 7.

Renaming my Windows 7 box from "mypc-win7" to "win7mypc" and a reboot all round fixed it for me. I.e. try removing any "special" characters from your win7 computer name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.