I run a Mac OS X 10.7.4 host and I use VirtualBox to run an Ubuntu 12.04 LTS guest. If it's helpful, it used to be 11.10 and it was updated in the VM when it came out.

Anyway, today I let the update manager have its way with Ubuntu and what resulted was an OS unable to run Unity (it falls back to Unity 2D). I didn't get a Google hit with someone having a similar issue, so I figured I'd ask for advice here.

I'm not used to having to debug issues with failed updates (since they're usually flawless, and I've never operated primarily out of a VM before) so I'm not sure what the best route would be to figure out which update caused an issue (perhaps an update failed and I didn't notice before the OS was rebooted?).

My hope was that I could at least get it working again by uninstalling then reinstalling VirtualBox guest additions (which didn't work) but ideally I'd like to know how I could debug the issue so when it's a package I have no idea about causes an issue I can debug it.

In any case, I can log in but I can't use the full Unity non-Unity2D (3D compatible version). How can I fix this?


The following is the output of running /usr/lib/nux/unity_support_test -p:

anthony:~> /usr/lib/nux/unity_support_test -p
Xlib:  extension "GLX" missing on display ":0".
Error: GLX is not available on the system

To clarify, 3D acceleration is enabled in VirtualBox. There is 128MB of video memory given to the VM. The system was running fine prior to running some routine updates today (whatever was there via the Ubuntu Update Manager tool). Afterward, the system is stuck falling back to Unity2D mode (apparently I don't have "GLX" anymore?).

  • Please edit question with the output of /usr/lib/nux/unity_support_test -p – ish Jun 8 '12 at 19:19
  • Would you please clarify what you mean by "but I can't use the full Unity". What is the problem you are trying to correct? Are you using VirtualBox v4.1.16 or some other version? Is 3-D acceleration enabled and 2-D acceleration disabled in your VB settings for the VM? How much video memory have you allocated? – irrational John Jun 8 '12 at 22:22
  • @izx Output added. That's interesting. @ irrationalJohn Clarification added. Hopefully that helps. – Anthony Jun 8 '12 at 23:42

During the testing in beta release something similar happened to me, installing guest additions from "Additionals Driver" did the trick.

  • The guest additions package was installed before and after this problem occurred. One of the first things I tried was completely reinstalling the package. Other parts I can see are clearly working (e.g. supporting larger screen resolutions) but for some reason not 3D acceleration. Did you mean something different than the virtualbox-guest-additions package? – Anthony Jun 9 '12 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.