Remmina connect from Ubuntu 22.04 Desktop PC (i.e. Client) to another Ubuntu 22.04 Desktop PC (i.e. Server) on LAN fails with "Could not find address for the RDP Server". The Server in the Remote Connection Profile is "ms-rd://Demonstrator.local". My router shows the Server is named DEMONSTRATOR with a static NAT address of, DEMONSTRATOR being 'defined' by the router even though /etc/hosts says its name is Demonstrator. I've tried changing the Security Protocol Negotiation from Automatic to RDP Security Protocol Security, but same result. Port 3389 is Open for TCP on the Server.

  • @netbat dig demonstrator.local & ping demonstrator both show connection Ok. I've tried ms-rd:// and that also failed. I forget where I got the .local from. I think that the problem is with xrdp: for some silly reason I didn't notice that it doesn't start. I'm not able to insert the Terminal output due to restrictions on this site. So here is a link to its txt file on my Box.com: app.box.com/s/revu7ppn1dhjo2dhftot2kb0h7tz6g5x Is there a better way of doing that on this site?
    – John Rose
    Aug 16 at 8:55

1 Answer 1


The computer running the Remmina client cannot resolve the demonstrator.local name to an IP address. Simply use the ping and dig commands to check this.

dig demonstrator.local

ping demonstrator.local

Does the connection work if you use the IP address instead of the name?


If so, the problem is just the name.

How did you come up with the domain extension local that you list after the demonstrator name?

I suppose a simple workaround that gets around (but doesn't fix) the domain name problem is to edit the /etc/hosts file on the Remmina client machine you want to connect from.

Add the line to the file /etc/hosts:   demonstrator

Then use that name without the "local" extension to connect:

  • I think that the problem is with xrdp which does not start properly. Current state is: I've just tried the changes outlined at pimylifeup.com/ubuntu-xrdp However, they did not solve the problem. I've logged this as bug 2031538 on Launchpad.
    – John Rose
    Aug 25 at 10:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .