yesterday my system (Ubuntu 22:04) started hanging on shutdown. I don't recall doing anything unusual before this issue started happening (it started when my computer froze and I had to restart manually). The same issue has been observed elsewhere (Ubuntu 22.04, Ubuntu 18.04, debian more generally, Mint/Archlinux/You name it). Most posts don't have a solution (notably the one for Ubuntu 22.04 mentioned above). The other ones are super confusing, specially for a not very experienced user like me.

Below is the text in the screen I get when the shutdown is hanging:

 [23.637071] wlp0s20f3: deauthenticating from d8:c6:78:6a:a8:ff by local choice (Reason 3=DEAUTH_ LEAVING)
 [23.855304] ACPI BIOS Error (bug): Could not resolve symbol [\_TZ.ETMD], AE_ NOT_FOUND (20221020/psargs-330)
 [23.855455] No Local Variables are initialized for Method [_OSC]
 [23.855514] Initialized Arguments for Method [_OSC]: (4 arguments defined for method invocation)
 [23.855568]   Arg0: 00000000e1f36073 <Obj>   Buffer(16) 5D AB 3B B2 B7 C8 42 35
 [23.855659]   Arg1: 000000005c3f6443 <Obj>   Integer 0000000000000001
 [23.855721]   Arg2: 0000000064ff173e <Obj>   Integer 0000000000000002
 [23.8557791  Arg3: 000000009dde1447 <Obj>   Buffer(8) 00 00 00 00 00 00 00 00
 [23.855878] ACPI Error: Aborting method \_SB.IETM. _OSC due to previous error (AE_NOT FOUND) (20221020/psparse-529)
 [25.135434] systemd-shutdown[1] : Syncing filesystems and block devices.
 [25.142780] systemd-shutdown[1]: Sending SIGTERM to renaining processes...
 [25.148588] systemd- journa lar364]: Received SIGTERM from PID 1 (systemd-shutdow).
 [25.163092] systemd-shutdownI1]: Sending SIGKILL to remaining processes.
 [25.168725] systemd-shutdown[1]: Unmounting file systems.
 [25.169501] [1871]: Remounting '/’ read-only in with options 'errors=remount-ro'.
 [25.175473] EXT4-fs (nvme0n1p2) : re-mounted a12a47la-c6c5-4244-9878-949903bd5799. Quota mode: none.
 [25.184031] systend-shutdown[1] : All filesystms unmounted.
 [25.184051] systemd-shutdown[1]: Deactivating swaps.
 [25.1840851 systemd-shutdown[1]: All swaps deactivated.
 [25.184095] systemd-shutdown[1] : Detaching loop devices.
 [25.1853481 systemd-shutdown[1]: All loop devices detached.
 [25.1853631 systemd-shutdown[1]: Stopping MD devices.
 [25.185431] systemd-shutdown [1]: All MD devices stopped.
 [25.185441] systemd-shutdown[1]: Detaching DM devices.
 [25.185484] systemd-shutdown[1]: All DM devices detached.
 [25.185496] systemd- shutdown[1]: All filesystems, swaps, loop devices, MD devices and DM devices detached.
 [25.2124031 systemd-shutdown[1] : Syncing filesystems and block devices.
 [25.212634] systemd-shutdown[1]: Rebooting.
 [25.212695] kvm: exiting hardware virtualization

What I gathered from the posts mentioned above is that this is either a kernel issue or something to do with the NVIDIA drivers. I am not a very experienced user so I am not sure what to do. I tried to shutdown the NVIDIA drivers on shutdown using the script I found here, but it didn't work (maybe I have to adapt the script, but I don't know how to do so). I haven't tried to update or downgrade my kernel since I am not sure what the consequences would be and because I am unsure to which version to downgrade/upgrade it to, but I am willing to try if you think that's the way to go.

My system specs:

Kernel: 6.2.0-26-generic


Distributor ID: Ubuntu
Description:    Ubuntu 22.04.3 LTS
Release:    22.04
Codename:   jammy

Graphic Card

   description: 3D controller
   product: GA107M [GeForce RTX 3050 Mobile]
   manufacturer: NVIDIA Corporation
   Physical ID: 0
   Bus information: pci@0000:01:00.0
   Logical name: /dev/fb0
   Version: a1
   Width: 64 bits
   clock: 33MHz
   Capacities: pm msi pciexpress bus_master cap_list rom fb
   Setting: depth=32 driver=nouveau latency=0 mode=1920x1200 visual=truecolor xres=1920 yres=1200
   Resources: memória de E/S:600-5ff memória de E/S:610-60f irq:205 memória:be000000-beffffff memória:6000000000-60ffffffff memória:6100000000-6101ffffff porta de E/S:3000(tamanho=128)
   description: VGA compatible controller
   product: Alder Lake-P Integrated Graphics Controller
   manufacturer: Intel Corporation
   Physical ID: 2
   bus information: pci@0000:00:02.0
   logical name: /dev/fb0
   version: 0c
   width: 64 bits
   clock: 33MHz
   capacities: pciexpress msi pm vga_controller bus_master cap_list rom fb
   setting: depth=32 driver=i915 latency=0 resolution=1920,1200
   resources: memória de E/S:610-60f memória de E/S:400-3ff irq:206 memória:6188000000-6188ffffff memória:4000000000-400fffffff porta de E/S:4000(tamanho=64) memória:c0000-dffff memória:4010000000-4016ffffff memória:4020000000-40ffffffff

Thanks for your help!


You must log in to answer this question.

Browse other questions tagged .