0

System Specifications:

  • Laptop: Clevo NP50PNH
  • Ubuntu Version: 22.04
  • Kernel: 6.2.0-26-generic
  • Display server: Wayland
  • Graphics card: NVIDIA GeForce RTX-3060 – 6 GB DDR6 Video Memory – DirectX 12.1 – 115W TDP

About a day ago my NVIDIA GeForce RTX-3060 card in my work laptop stopped working. This resulted in no longer being able to use the HDMI port, The USB-C Thunderbolt was still available though. I found out the laptop switched back to the onboard Intel iRISxe graphics. When I try to see if there are any additional drivers it tells me that there a not additional drivers available, where previously I had a host of choices. Previously I was using the nouveau driver for a month or so since the proprietary Nvidia drivers where giving me a number of problems. And since this is a work laptop used for programming I don't need very much fancy graphics, just be able to use the HDMI.

My apt is up to date atm. The Bios of this laptop is very very limited so I'm not sure of going there would help at all so I haven't tried that yet.

I tried

  • apt-update & apt-upgrade
  • Checked for additional drivers.
  • Tried to switch Nvidia using prime-select.
  • Reboot

Relevant output of lspci

00:00.0 Host bridge: Intel Corporation 12th Gen Core Processor Host Bridge/DRAM Registers (rev 02)
00:01.0 PCI bridge: Intel Corporation 12th Gen Core Processor PCI Express x16 Controller #1 (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Alder Lake-P Integrated Graphics Controller (rev 0c)
00:04.0 Signal processing controller: Intel Corporation Alder Lake Innovation Platform Framework Processor Participant (rev 02)
00:06.0 PCI bridge: Intel Corporation 12th Gen Core Processor PCI Express x4 Controller #0 (rev 02)
00:07.0 PCI bridge: Intel Corporation Alder Lake-P Thunderbolt 4 PCI Express Root Port #0 (rev 02)
00:08.0 System peripheral: Intel Corporation 12th Gen Core Processor Gaussian & Neural Accelerator (rev 02)
00:0a.0 Signal processing controller: Intel Corporation Platform Monitoring Technology (rev 01)
00:0d.0 USB controller: Intel Corporation Alder Lake-P Thunderbolt 4 USB Controller (rev 02)
00:0d.2 USB controller: Intel Corporation Alder Lake-P Thunderbolt 4 NHI #0 (rev 02)
00:14.0 USB controller: Intel Corporation Alder Lake PCH USB 3.2 xHCI Host Controller (rev 01)
00:14.2 RAM memory: Intel Corporation Alder Lake PCH Shared SRAM (rev 01)
00:14.3 Network controller: Intel Corporation Alder Lake-P PCH CNVi WiFi (rev 01)
00:15.0 Serial bus controller: Intel Corporation Alder Lake PCH Serial IO I2C Controller #0 (rev 01)
00:15.1 Serial bus controller: Intel Corporation Alder Lake PCH Serial IO I2C Controller #1 (rev 01)
00:16.0 Communication controller: Intel Corporation Alder Lake PCH HECI Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation Device 51bd (rev 01)
00:1f.0 ISA bridge: Intel Corporation Alder Lake PCH eSPI Controller (rev 01)
00:1f.3 Audio device: Intel Corporation Alder Lake PCH-P High Definition Audio Controller (rev 01)
00:1f.4 SMBus: Intel Corporation Alder Lake PCH-P SMBus Host Controller (rev 01)
00:1f.5 Serial bus controller: Intel Corporation Alder Lake-P PCH SPI Controller (rev 01)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (16) I219-V (rev 01)
01:00.0 VGA compatible controller: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GA106 High Definition Audio Controller (rev a1)
02:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller PM9A1/PM9A3/980PRO
2c:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)

This clearly shows the card is still present

sudo prime-select nvidia gives me this:

Info: selecting the nvidia profile
Deleting /lib/modprobe.d/nvidia-runtimepm.conf
Updating the initramfs. Please wait for the operation to complete:
-W: Possible missing firmware /lib/firmware/nvidia/ga107/acr/ucode_ahesasc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/acr/ucode_ahesasc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/acr/ucode_ahesasc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/acr/ucode_ahesasc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/acr/ucode_ahesasc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/acr/ucode_asb.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/acr/ucode_asb.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/acr/ucode_asb.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/acr/ucode_asb.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/acr/ucode_asb.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/nvdec/scrubber.bin for module nouveau
|W: Possible missing firmware /lib/firmware/nvidia/ga107/gr/NET_img.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/gr/NET_img.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/gr/NET_img.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/gr/NET_img.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/gr/NET_img.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/gr/fecs_bl.bin for module nouveau
\W: Possible missing firmware /lib/firmware/nvidia/ga107/sec2/hs_bl_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga107/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/sec2/hs_bl_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga106/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/sec2/hs_bl_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga104/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/sec2/hs_bl_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga103/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/sec2/hs_bl_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/ga102/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/i915/dg2_huc_gsc.bin for module i915
Done

But rebooting after sudo prime-select nvidia does nothing. Btw, reboot/power off seems to get stuck when powering down, even when I wait a couple of minutesm and I need to do a 5 second button press to actually shut the system down atm. Not sure if this is related or not.

Output of journalctl -b -1 -r is

aug 09 09:12:46 michel-linux-laptop systemd-journald[914]: Journal stopped
aug 09 09:12:46 michel-linux-laptop systemd-shutdown[1]: Sending SIGTERM to remaining processes...
aug 09 09:12:46 michel-linux-laptop systemd-shutdown[1]: Syncing filesystems and block devices.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Shutting down.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Reached target System Power Off.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Finished System Power Off.
aug 09 09:12:46 michel-linux-laptop systemd[1]: systemd-poweroff.service: Deactivated successfully.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Reached target Late Shutdown Services.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Reached target System Shutdown.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Stopped Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling.
aug 09 09:12:46 michel-linux-laptop systemd[1]: lvm2-monitor.service: Deactivated successfully.
aug 09 09:12:46 michel-linux-laptop lvm[78362]:   2 logical volume(s) in volume group "vgubuntu" unmonitored
aug 09 09:12:46 michel-linux-laptop systemd[1]: Stopped Remount Root and Kernel File Systems.
aug 09 09:12:46 michel-linux-laptop systemd[1]: systemd-remount-fs.service: Deactivated successfully.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Stopped Create System Users.
aug 09 09:12:46 michel-linux-laptop systemd[1]: systemd-sysusers.service: Deactivated successfully.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Stopped Create Static Device Nodes in /dev.
aug 09 09:12:46 michel-linux-laptop systemd[1]: systemd-tmpfiles-setup-dev.service: Deactivated successfully.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Stopping Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling.>
aug 09 09:12:46 michel-linux-laptop systemd[1]: Stopped target Preparation for Local File Systems.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Removed slice Slice /system/systemd-fsck.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Stopped File System Check on /dev/disk/by-uuid/e1bce27a-a986-49e3-bb2c-a3e736585fe4.
aug 09 09:12:46 michel-linux-laptop systemd[1]: systemd-fsck@dev-disk-by\x2duuid-e1bce27a\x2da986\x2d49e3\x2dbb2c\x2da3e736585fe4.servi>
aug 09 09:12:46 michel-linux-laptop systemd[1]: Reached target Unmount All Filesystems.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Unmounted /boot.
aug 09 09:12:46 michel-linux-laptop systemd[1]: boot.mount: Deactivated successfully.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Deactivated swap /dev/mapper/vgubuntu-swap_1.
aug 09 09:12:46 michel-linux-laptop systemd[1]: dev-mapper-vgubuntu\x2dswap_1.swap: Deactivated successfully.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Deactivated swap /dev/dm-2.
aug 09 09:12:46 michel-linux-laptop systemd[1]: dev-dm\x2d2.swap: Deactivated successfully.
aug 09 09:12:46 michel-linux-laptop systemd[1]: Deactivated swap /dev/disk/by-id/dm-uuid-LVM-OvXIAKj2mAprMp7xlc862ptZi0ZX9D3Lumy4AVs3ty>

Conclusion: I'm trying to restore the functionality of my Nvidia card and HDMI. Any help or pointers would be greatly appreciated.

Update I am not using any NVIDIA drivers, or rather I don't know what driver I am using atm, since there are at the moment none available to me. That is the whole problem atm. I was using the noveau driver, since that one gave me less trouble when switching from home office to office screens out of suspend. But the whole problem is that I have the feeling that the laptop switched to the onboard Intel Iris Xe Graphics earlier this week. This prevents me from using the HDMI port, and limits my external screen options to Thunderbolt.

This is how my drivers selection looks like right now enter image description here

The ubuntu-drivers devices command gives no output at all

prime-select query give me the output of nvidia, but I would expect to be able to select a NVIDIA driver and use my HDMI port if that was the case

lshw -numeric -C display gives

*-display                 
       description: VGA compatible controller
       product: GA106M [GeForce RTX 3060 Mobile / Max-Q] [10DE:2520]
       vendor: NVIDIA Corporation [10DE]
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: /dev/fb0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=nouveau latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
       resources: iomemory:600-5ff iomemory:620-61f irq:167 memory:83000000-83ffffff memory:6000000000-61ffffffff memory:6200000000-6201ffffff ioport:3000(size=128) memory:84080000-840fffff
  *-display
       description: VGA compatible controller
       product: Alder Lake-P Integrated Graphics Controller [8086:4626]
       vendor: Intel Corporation [8086]
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 resolution=1920,1080
       resources: iomemory:620-61f iomemory:400-3ff irq:168 memory:6202000000-6202ffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

sudo lspci -vnn | grep VGA gives

00:02.0 VGA compatible controller [0300]: Intel Corporation Alder Lake-P Integrated Graphics Controller [8086:4626] (rev 0c) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] [10de:2520] (rev a1) (prog-if 00 [VGA controller])
3
  • 1
    There have been many reports of similar problems recently. A workaround that is frequently suggested is to interrupt the boot at the grub screen, select advanced options, and boot into an older kernel. Aug 10, 2023 at 13:51
  • 1
    That seems to work for now, I went back to 5.19.0-50-generic. i can now see all my available drivers and HDMI is working again. If you add this as answer I will accept it as the correct answer
    – Sitethief
    Aug 11, 2023 at 8:28
  • 1
    I'm glad it helped you. Stay tuned for a real answer, my suggestion is just a workaround. Aug 11, 2023 at 11:00

1 Answer 1

1

I had same issue in a Dell G15. I had to purge nvidia drivers and then reinstall sudo apt purge nvidia-*

sudo apt purge nvidia-*

sudo apt install nvidia-driver-xxx

The problem here is the driver for RTX 3060. Initialy I installed nvidia-driver-470 and it installed and select 470. it worked in "join displays" but with a lot of lag in "single display". Then in "sotware & updates->additional drivers" I changed to 535 that worked ok.

3
  • that gives no matches found: nvidia-*, I'll try to install 535 and see where I end up
    – Sitethief
    Sep 7, 2023 at 13:45
  • I do see nvidia drivers now under the newest kernel, I can't test the HDMI cable yet. If that works I will accept this solution
    – Sitethief
    Sep 8, 2023 at 6:58
  • This worked, I can now once again use my HDMI port, and use the propietrary 535 Nvidia driver under the recent 6.2.0-32-generic kernel.
    – Sitethief
    Sep 13, 2023 at 7:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .