In Ubuntu 12.04 (or above), how do I set the GRUB time and the default OS (that I see at boot time) as I'm dual-booting Windows (7/8) and Ubuntu (12.04 or above)?

  • Can you give more information. What do you mean with "grub time" and what is your default os. In your grub menu what are the different lines? – Julien Chau Jun 8 '12 at 10:16
  • 1
    grub time means the countdown time when i have to select the os at the BIOS starting screen. I'm sorry but I don't know exactly what that os selection menu is called so I posted it as grub time. – meteors Jun 8 '12 at 13:23
up vote 209 down vote accepted
  • Press Alt + F2, type gksudo gedit /etc/default/grub press Enter and enter your password.
  • You will see the following contents:

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    
  • You can change the default from 0 to any number, corresponding to the entry in the Grub bootup menu (first entry is 0, second is 1, etc.)

  • You can change the "hidden timeout" (no menu); and also display the countdown (GRUB_HIDDEN_TIMEOUT_QUIET=false)
  • You can force the grub menu to show by commenting out the two GRUB_HIDDEN lines with a # at the beginning of the line
  • And set the grub menu timeout (default is 10 seconds)

  • Make your changes, press Ctrl + S to save and Ctrl + Q to exit

  • Important: Open a terminal with Ctrl + Alt + T and type sudo update-grub to apply the changes you just made
  • Reboot and you should see your timeout/default entry change

Linked Question:

  • Thanks, @Raja, but grub/grub2 was the main difference. If you had the correct grub2, I would have happily edited your answer instead of making another one :) – ish Jun 8 '12 at 10:24
  • thank you your answer worked but can u please explain me the second and third point(the hidden timeout and grub hidden lines) what are they meant for. – meteors Jun 8 '12 at 13:34
  • 2
    Please don't recommend anyone change the default grub option by setting an arbitrary index. That's terribly unintuitive and likely to result in disaster. The user may enter the wrong one, or it may change during an upgrade, resulting in unexpected behaviour. – Cerin Apr 12 '15 at 17:52
  • 2
    This needs an update related to the dual levels of current grub menu. – Hannu Aug 21 '15 at 9:48
  • 1
    @Cerin what's your suggestion then? – Blauhirn Jan 24 '17 at 13:08

If you read the file that you are editing in the example above (/etc/default/grub), you will notice that the very first couple lines instruct you to run update-grub after making changes in order to update the actual file that grub reads to "get its instructions" (/boot/grub/grub.cfg). Note that you must actually run it with the sudocommand first as you need root privileges to actually run the command (which is why the poster above said to type sudo update-grub). This will cause the changes you made to be written to /boot/grub/grub.cfg. The very next couple lines tell you that you can read the full documentation of options in that file (again, /etc/default/grub) by typing info -f grub -n 'Simple configuration'.

That said, set GRUB_TIMEOUT to -1 if you want to set the "grub time" to be indefinite. In other words, it will never automatically boot. You will have to make a selection.

Finally, to answer your question, here are the descriptions of those "grub hidden lines" straight from the above-referenced documentation:

GRUB_HIDDEN_TIMEOUT
    Wait this many seconds for a key to be pressed before displaying
    the menu.  If no key is pressed during that time, boot
    immediately.  Unset by default.

GRUB_HIDDEN_TIMEOUT_QUIET
    In conjunction with `GRUB_HIDDEN_TIMEOUT', set this to `true' to
    suppress the verbose countdown while waiting for a key to be
    pressed before displaying the menu.  Unset by default.

I hope this helps!

You can use an application called Grub Customizer. It is much more easier.

You can install it by:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

There is an How-To Geek article about it, How to Configure the Linux GRUB 2 Boot Menu the Easy Way. Also, there is a solved thread on the Ubuntu Forums, Change boot order in GRUB 2 that mentions this tool.

Here are some screen shots of this software:

screen_1

screen_2

screen_3

  • This needs an update related to the dual levels of current grub menu. – Hannu Aug 21 '15 at 9:48

I followed the first answer but it seems to need updating if you are dual booting with Windows 7 Pro and Ubuntu 16.04. Also make sure secure boot is off in the BIOS.

a) First he says use Alt + F2 when I think he wants to use to open a terminal window. In my case it is Ctrl+Alt+T.

b) In the first entry gksudo gedit /etc/default/grub the gksudo command is not installed by default in Ubuntu 16.04. To get around this do the following in Terminal:

sudo -i and press Enter and give your password and then Enter again.

then type:

gedit /etc/default/grub and press Enter.

c) You will now see the grub change menu as illustrated in answer 1. Follow his answer until he gets to Ctrl + S to save the changes. This doesn't work in Ubuntu 16.04 but you should see a save button in the upper right corner of the screen. Click on that.

d) Ctrl + Q to quit.

e) Next type sudo update-grub and Enter

f) Type exit. You need to do this twice.

g) Reboot

I found that on my computer after a few logons the boot process would not show the grub screen at start up and therefore I could not get into Ubuntu as I had set Windows as my default bootup with a 7 second delay in case I wanted to get into Ubuntu.

To correct this problem you need to get into Windows.

  1. Click on the start menu and type CMD in the search box.

  2. Right click on the CMD line which should be at the top of the screen produced by the right clicking.

  3. Click on run as administrator.

  4. On the command line type bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi. This entry has the effect of registering the grub menu with the windows boot manager. (Credit to: Grub not showing on startup for Windows 8.1 Ubuntu 13.10 Dual boot)

  5. Finally, I rebooted back into windows.

I hope this helps.

  • Can you please link to "illustrated in answer 1" - I couldn't find what you meant. – Tom Hale Sep 22 '16 at 5:49
  • Also "I followed the first answer". You can you my "Credit to:" formatting as an example. Great first post. Welcome to AskUbuntu. – Tom Hale Sep 22 '16 at 6:25
  • I've had X-window break in odd ways when running graphical applications like gedit as sudo. I suggest using a text-based editor like nano instead. – Arthur Tacca Jun 11 '17 at 15:46
  • 2
    Alt+F2 is the unity shortcut to run a command in the background. In the menu that opens, you can enter any command like you would in the terminal. But since it doesn't open a terminal you won't see any terminal output and can't interact with the terminal. That's why you would typically use it for things like starting a GUI program like gedit. Also you can't use sudo since you need the terminal for that. That's why they use gksudo (the GUI sudo). If you do the commands in a terminal, you can just use the normal sudo like this: sudo gedit /etc/default/grub no need for sudo -i. – Sebastian Jul 20 '17 at 9:03
  • @Sebastian For launching a graphical app, sudo -H is better, i.e. sudo -H gedit /etc/default/grub. – wjandrea Sep 9 at 0:49

Using default entry based on a number astonished me since its introduction in GRUB. This is really bad idea. How about kernel update and automatic grub re-configuration? How about unaware users that prefer entry at the end of the list? Updates would break that default number based configuration.

Instead use SAVED option here to remember last chosen entry:

GRUB_DEFAULT=SAVED
GRUB_SAVEDEFAULT=TRUE

Then apply GRUB with

sudo update-grub
  • 1
    Not a big problem, but this doesn't explain how or where to make these changes. You might want to link to another answer that does. – wjandrea Sep 9 at 0:55

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.