0

I have a Home Assistant virtual machine in Virtual Box. I typically access it using GUI, but now i'm using the device in a headless setup, so i'm trying to open it using ssh access.

The issue I encountered while opening virtualbox ($ virtualbox) with a headless setup:

Qt FATAL: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Aborted (core dumped)

I have tried $ sudo purge virtualbox and $ sudo install virtualbox to reinstall the program.

It didn't help.

I reinstalled oracle extension pack using $ sudo apt install virtualbox-ext-pack and using $ sudo modprobe vboxdrvhere to avoid configuration errors.

I also tried to update packages using $ sudo apt update.

And upgrading them using $ sudo apt upgrade, and also upgrading individual packages listed using $ apt list --upgradable and $ sudo apt-get install --only-upgrade $PACKAGE for remaining 28 packages.

I still can't open virtualbox using ssh.

Note: I'm quite new to all of this so I would greatly appreciate a more detailed answer for a newbie like me.

1 Answer 1

0

Issue is solved by using command DISPLAY=:0 nohup $PROGRAM from this thread. Updating host device version and extension pack I think helped solve some other issues the device was having.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .