I have installed Ubuntu 12.04LTS on Lenovo S205 twice, but it would not boot normally. How can I fix this problem? I tried to install dual boot, Windows and Ubuntu. but still it would not work properly. Even, when I installed Ubuntu only, it would not boot too. Installation was okay, but it could not boot to Ubuntu. just stuck on a blank screen. More information is posted in my blog below


extremely need a help.


2 Answers 2


Try using this guide, this combo finally worked for me:


  1. Write Ubuntu 64 bit live USB (32 bit won't work due to UEFI)
  2. Make at least 3 primary partitions:
    • 125MB EFI partition (Only appears in ubuntu installer. Does not appear in gParted, or Linux Mint installer)
    • / partition (ext4 is fine)
    • swap partition (swap)
    • If you do not see "EFI" partition type during the installer, try opening gParted in the live USB and make an GPT partition table before you do the installation. It's in one of the menus (you don't want msdos).
  3. Install
  4. After your first restart after installing, go into the BIOS boot menu (F2) and rearrange the boot partitions to your HDD as #1 and the new mysterious "ubuntu" entry is #2. This will enable your wifi (after all what is a netbook without wifi).

LUG Bruchsal have fixed your problem. Just visit their homepage. The Homepage is in German but it should not be a serious problem. You are able to translate with www.leo.org. enjoy yourself with best greetings from a ubuntu- user witch have the same problem in front of his chest!

Reinhard (Germany)

Homepage: https://lugbruchsal.de/dokuwiki/doku.php?id=doku:ubuntu_12.04_auf_lenovo_s205_installieren

Give me just a shout if it will be worked out with your netbook.

  • 1
    Welcome to AskUbuntu. This link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. Thanks!
    – penreturns
    Oct 15, 2012 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.