I'm running Windows XP as a VirtualBox guest OS under Ubuntu 11.10, and I can't browse the Windows network. It seems like I can connect to some specific network shares, maybe only ones that are already mapped to drives.

If I disable ufw, it all works fine, and when I enable it again, the network browsing continues to work. I tried looking at /var/log/ufw.log and saw it blocking port 138. When I allowed that port, then I saw it blocking port 137.

I found this answer, and it led me to bug 360975. The bug originally asked for both nf_conntrack_pptp and nf_conntrack_netbios_ns to be added to the defaults, but in comment 11, Jamie decided not to include nf_conntrack_pptp in the fix.

I tried adding it in, and it seemed to solve my problem, but then the problem came back.

How can I let the Windows guest OS browse the local network?


Changing the VirtualBox network settings from NAT to bridged adapter solved the problem. It continued to work after I removed the nf_conntrack_pptp module, so I guess that was irrelevant.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.