3

i use Ubuntu 23.04 ‘Lunar Lobster’ as my os
and i'm trying to open rofi but i got

(process:24596): Rofi-WARNING **: 01:06:51.568: Failed to set locale.

so it seems it has a thing with locales after some research i figure out an odd issue

i've checked /etc/locale.gen file and uncommete ar_EG.UTF-8 UTF-8 line and regenerate locales after editing /etc/locale.gen with command : sudo locale-gen

and i got this

Generating locales (this might take a while)...
  ar_EG.UTF-8... done
  ar_AE.UTF-8... done
  ar_BH.UTF-8... done
  ar_DZ.UTF-8... done
  ar_EG.UTF-8... done
  ar_IN.UTF-8... done
  ar_IQ.UTF-8... done
  ar_JO.UTF-8... done
  ar_KW.UTF-8... done
  ar_LB.UTF-8... done
  ar_LY.UTF-8... done
  ar_MA.UTF-8... done
  ar_OM.UTF-8... done
  ar_QA.UTF-8... done
  ar_SA.UTF-8... done
  ar_SD.UTF-8... done
  ar_SS.UTF-8... done
  ar_SY.UTF-8... done
  ar_TN.UTF-8... done
  ar_YE.UTF-8... done
  en_AG.UTF-8... done
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IL.UTF-8... done
  en_IN.UTF-8... done
  en_NG.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZM.UTF-8... done
  en_ZW.UTF-8... done
Generation complete.

so why i got all of this locales should it be just two locales ? command : grep -v ^# /etc/locale.gen output

ar_EG.UTF-8 UTF-8
en_US.UTF-8 UTF-8

even tho localectl command doesn't show anything in System Locale except en_US.UTF-8 where's ar_eg.utf-8 ?

System Locale: LANG=en_US.UTF-8
    VC Keymap: (unset)         
   X11 Layout: us
    X11 Model: pc105

more info with commands and output :

command localectl list-locales

C.UTF-8
ar_AE.UTF-8
ar_BH.UTF-8
ar_DZ.UTF-8
ar_EG.UTF-8
ar_IN.UTF-8
ar_IQ.UTF-8
ar_JO.UTF-8
ar_KW.UTF-8
ar_LB.UTF-8
ar_LY.UTF-8
ar_MA.UTF-8
ar_OM.UTF-8
ar_QA.UTF-8
ar_SA.UTF-8
ar_SD.UTF-8
ar_SS.UTF-8
ar_SY.UTF-8
ar_TN.UTF-8
ar_YE.UTF-8
en_AG.UTF-8
en_AU.UTF-8
en_BW.UTF-8

my problem seems to be that i have literally All of the available locales enabled why is that my /etc/locale.gen file just has 2 enabled locales !!! does i have a package interfering with rofi??

3
  • oooh i'm sorry maybe i forget to mention that i'm using Ubuntu 23.04 ‘Lunar Lobster’ and no it's not a server just my regular os
    – Adam
    Jul 26, 2023 at 0:47
  • If if's not a server install; then Ubuntu 23.04 Desktop would be more precise than 23.04 (which could be Desktop or Server)
    – guiverc
    Jul 26, 2023 at 1:07
  • Desktop not a serrver
    – Adam
    Jul 26, 2023 at 1:12

1 Answer 1

3

i've fixed it by deleting insatlled lang via setting => manage installed languages => install / remove languages and then delete arabic and extra eniglish lang i don't need my output has become now look like this

command : sudo locale-gen

Generating locales (this might take a while)...
  ar_EG.UTF-8... done
  en_US.UTF-8... done
Generation complete.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .