1

I've setup my desktop to Dual Boot Windows 11 & Ubuntu 22.04. It works flawlessly ~50% of the times, but the problems I experience are:

  • POST times are very inconsistent, sometimes it POSTs in three seconds, sometimes it POSTs in five minutes. The boot selector also sometimes automatically selects Ubuntu in like 3 seconds, and sometimes it waits for like 20 seconds before auto booting Ubuntu if I haven't made a manual selection.
  • Sometimes the PC doesn't POST at all, as in nothing is outputted to the screen, the PC isn't trying to reboot itself, it's just stuck before POSTing (maybe it will eventually boot? I've let it run for like 20minutes without POSTing before manually restarting).
  • After some failed POST attempts it POSTs in Safe Mode, and following that sometimes my Ethernet isn't detected in mostly Windows for a few reboots, but sometimes Ubuntu as well.
  • Sometimes it comes to that "No Keyboard Detected" screen when trying to POST, and then it goes away a few seconds later before I'm presented with the boot options, usually the keyboard doesn't work for a few seconds then.

These are my desktop specs:

  • I9 13900KS
  • RTX 4090
  • ASUS ROG MAXIMUS Z790 HERO
  • G.Skill Ripjaws S5 DDR5-6000 CL30 32GB
  • Samsung 990 PRO SSD 2TB (Windows)
  • Samsung 990 PRO SSD 1TB (Ubuntu)

I'm also running all of my peripherals except for my monitor to a CalDigit TS4 Thunderbolt 4 dock (Ethernet, Mouse, Keyboard, Headset).

What I've tried:

  • Turning off Fast Boot in BIOS.
  • Turning off Hybrid Sleep in Windows.
  • I haven't tried turning off Secure Boot, but I need to have it enabled in order to use some Anti-Cheat softwares used in Counter-Strike.
  • Toggled Turn Core Isolation Memory Integrity in Windows on/off.
  • Tried running Ubuntu in Xorg & Wayland
  • Doing the normal updating: sudo apt-get clean -> sudo apt-get update && sudo apt-get upgrade

SMALL BREAKTHROUGH: I tried unplugging my CalDigit TS4 dock when the computer was stuck in a trying to POST but not POSTing forever loop, then I instantly got the "No Keyboard Detected!" screen and then it POSTed. From my understanding everything should be the same until the boot loader that get's me into the boot options happens, which is after POST. This issue is happening before POST. I'm not entirely sure what to do with this information :S

I'm a bit unsure of how to debug this further, but it's getting quite annoying to use my PC. I didn't experience any of these issues whilst only running Windows, they started when I installed my other drive in my system, and then installed Ubuntu on it. I'm honestly quite unsure how to debug this further, I'd appreciate any help you could provide. Thanks in advance!

4
  • Failure to POST is a hardware problem, long before any OS involvement. Try disconnecting your dock, maybe use just a USB hub for KB mouse, and see if problems goes away.
    – ubfan1
    Jul 19, 2023 at 16:12
  • The output of sudo cat /var/log/boot.* can be helpful.
    – Raffa
    Jul 19, 2023 at 16:35
  • @ubfan1 Yeah, I know, but it only started happening after I installed Ubuntu, that's my reason for posting here. The issue is, if I don't use my dock I don't have an easy way of switching between my Mac and my PC, now it's just changing one cable that I have readily available on my desk. Jul 19, 2023 at 20:26
  • @Raffa I will look into it tomorrow morning, thanks for the tip! Jul 19, 2023 at 20:26

0

You must log in to answer this question.

Browse other questions tagged .