8

When I open a photo in eog I can easily zoom with the mouse mouse wheel. This is kind of nice but since I have a touchpad with two-fingered scrolling and horizontal scrolling I'd rather scroll in the image and zoom by using Ctrl+Mouse Wheel?

I basically want the same behaviour as in evince: Horizontal Scroll and Normal Scroll navigate within the image and Ctrl + Mouse Wheel zooms in and out.

Is this possible somehow?

[EDIT] I just figured out that what I want is already implemented: I can pan the image by using Ctrl + Mouse Wheel. This is fine as it is the behaviour I want only with the Ctrl inverted. But I cannot pan to the left. Up, down and right work fine. What's the problem?

14

Wauzl, try to set value of the property «scroll-wheel-zoom» to false.

gsettings set org.gnome.eog.view scroll-wheel-zoom false

Also, you can list other EOG properties:

gsettings list-recursively | grep -i eog
2
  • Setting org.gnome.eog.view scroll-wheel-zoom to true not only anwered my question but also enables me to pan to the left. Is this a bug in eog or due to my settings? – Wauzl Feb 18 '13 at 11:17
  • I use Eye of Mate, with the Mate Desktop. I'm kind of guessing the same should more or less apply, shouldn't it? – Augustin Riedinger Mar 30 '15 at 7:52
1

To fix the backwards keybindings under eom - Eye of Mate, use the following:

gsettings set org.mate.eom.view scroll-wheel-zoom false

Then restart it. ;-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.