7

Since I did some updates from Software Updater, Chrome isn't working. I can open it but all the web pages that I go in to, doesn't load completely, though the little black wheel is not indicating that is still working. I've already tried to update Chrome, reinstall, delete and install it again but is still the same. Thanks in advance for your help. There's an image of Youtube's main page and that's how Chrome is showing the web pages.

1
  • 1
    I have the same problem, I have recently updated my PC with Xubuntu and Chrome, Opera and Brave don't load pages properly: not all the images are loaded, there is some "styles" missing, etc. It is curious that Chromium works correctly and also Firefox Commented Jul 11, 2023 at 0:20

2 Answers 2

5

This seems like a configuration version mismatch issue ... Although newer versions should deal properly with old configuration files, but sometimes things that are not expected happen e.g. corruption, invalid lock/status files, user installed extensions, outdated/invalid website specific caches/settings ... etc.

At this point and before proceeding, in Google Chrome, you might want to login to your Google account, "turn on sync" and wait until all your personal settings get saved in your google account … This will make it easier to restore them after your browser is fixed.

To see if this is the case, close Google Chrome first ... Then backup its configuration directory(should be ~/.config/google-chrome) by renaming it like so:

mv ~/.config/google-chrome ~/.config/old-google-chrome

Now, open Google Chrome and visit a website to see if it works normally and if that is the case, then you know what the culprit is.

Now, your Google Chrome is almost like a clean install ... To restore your previous settings, history, bookmarks ... etc.:

  • The preferred way is to login to your Google account and "turn on sync" if you have that enabled previously previously and that should restore all your saved settings ... Please see the comment by @xtrchessreal(Thank you @xtrchessreal for confirming that)

  • Or, alternatively, you can close Google Chrome again and copy the old configuration directory's contents over to the new configuration directory with cp's option -n, --no-clobber(do not overwrite an existing file) like so:

    cp -nr ~/.config/old-google-chrome/* ~/.config/google-chrome/
    

    Oftentimes, this will keep the newly created version specific configuration files made correctly when you last launched Google Chrome and restore your old configuration.

    In rare times, you might need to selectively copy over the contents of the old configuration directory until you isolate the cause.

5
  • Thank you! It worked! Although, when I tried to restore previous settings, etc, it went back as it was before, like the web page flashing and not loading correctly so I had to go back to the first step you've described and left it like that. Thanks Raffa!
    – MexTaco
    Commented Jul 11, 2023 at 23:26
  • I followed your answer, the websites work properly but I've had to set my bookmarks to view them again where before they where always showing. The tiny icons are not present inside the bookmarks and subfolders. Now I am worried that my sync may be wiped out if I turn it on again. It used to be on normally as a standard. If you know please help and complete the answer to show the next steps - thank you. If its just that Chrome believes this is a new computer then I should be able to turn on sync and everything will come back - right? Waiting for confirmation before taking further steps. Commented Jul 12, 2023 at 11:56
  • 1
    @xtrchessreal If you just follow the first step to rename the configuration directory and do not copy back any of the old configuration files in the second step, then you will notice that you are not logged-in to your google account anymore which means it is almost like a new installation ... So, logging-in should synchronize like a new Google Chrome install does ... I haven't tried it myself though so I can't confirm it, but it should.
    – Raffa
    Commented Jul 12, 2023 at 12:07
  • 1
    @Raffa Yes I was not logged, which I then did but the sync function is something you must do additionally. Click on your profile top right it asks to "turn on sync?" you click "Yes I'm in" then you must enter your passphrase. This should then load everything as before. I still had to go to history and "restore all tabs" to get back completely. These websites then need to be logged in again, if you have Saved Passwords its just a matter of clicking what is stored in Saved Passwords memory. I'm all good now, thank you for the extra help. Commented Jul 12, 2023 at 12:40
  • @xtrchessreal Many thanks for confirming that ... I added it to the answer.
    – Raffa
    Commented Jul 12, 2023 at 13:36
3

For me seemed the issue is to do with Hardware acceleration (Ubuntu 22.04, Version 114.0.5735.198 (Official Build) (64-bit))

chrome://settings/system uncheck Hardware Acceleration and relaunch.

3
  • 1
    this one worked for me Commented Jul 13, 2023 at 8:02
  • Worked for me too. Navigation is slow but at least pages does not look destroyed anymore.
    – Capy
    Commented Jul 14, 2023 at 13:21
  • Hardware Acceleration seems to be partially fixed in Chrome Version 115.0.5790.98 (Official Build) (64-bit) and can be reenabled. Commented Jul 18, 2023 at 23:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .