Yesterday I upgraded my system with sudo apt-get upgrade. I upgrade on a regular basis so not a lot of packages were installed and i don't know which ones this time. But after that i booted my computer and he hangs on "Checking battery state".

I googled a bit and i could manage to start Unity, how:

crtl+alt+f1 to open a terminal
startx (this starts the graphical stuff)
once that was started i opened a terminal with ctrl+alt+T
and then the command: unity &disown

Now everything works as normal. But this is annoying, and how can this be fixed. After googling a while i guess that it has something to with my video card.

The info:

~$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6400M Series
OpenGL version string: 4.2.11631 Compatibility Profile Context

My video card: Radeon 6470M

I also tried to download the driver from http://www2.ati.com/drivers/linux/amd-driver-installer-12-4-x86.x86_64.run and followed these instructions https://help.ubuntu.com/community/BinaryDriverHowto/ATI but my system still hangs at boottime.

What do i need to do to get my system boot as normal again. If you need additional info let me know.

Edit: somehow Ubuntu can't work anymore with the proprietary drivers from Ati for Radeon HD 6400M Series. I reinstalled Ubuntu and everything works fine (at first sight), but i want to install the proprietary drives. Now the problem is that i can't connect a second screen to my laptop anymore ... therefore i need the proprietary driver

  • I had never seen &disown before. Excellent. To fix this completely I think you will have to figure out what is going wrong. Two things occur to me, either compiz isn't set up properly to start unity or there is a timing issue. ~/.xsession-errors or /var/log/syslog or /var/log/Xorg.0.log may have some hints in any case. You might also try logging into ubuntu-2d or onto unity with a different user-id to help narrow down what is happening or use radeon rather than fglrx. Does ~/.gconf/apps/compiz-1/general/screen0/options/%gconf.xml contain a string "unityshell" and "unitymtgrabhandles"? – John S Gruber Jun 7 '12 at 21:03

After a few days I did a sudo apt-get upgrade again and I was able to install the proprietary driver again. Now everything works correctly again.

  • Cool--it seems the problem may have been fixed with an update (after having been introduced by an earlier update). – Eliah Kagan Jun 11 '12 at 7:55

Follow this steps (I've done the steps now, so I don't know if they work):

  1. Press Ctrl+Alt+F1.
  2. Type cd ~ (if you opened a folder before)
  3. Type nano .bash_profile
  4. Add to the file unity &disown
  5. Press Ctrl+X, now press Y.
  6. Reboot your computer typing sudo reboot and typing your password.
  • With this answer I believe you will still have to sign on to vt1 with Ctrl+Alt+F1 to run startx, but this will save you some typing. – John S Gruber Jun 7 '12 at 20:48
  • Thanks, but this still doesn't solve the issue, this ensures that Unity gets started after logon. – lukin Jun 8 '12 at 7:17
  • Then I have no idea :/ – espectalll Jun 9 '12 at 9:55
  • Even for reinstall the drivers, I have no idea. – espectalll Jun 9 '12 at 9:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.