0

I installed Ubuntu server on a 2011 iMac and set up the WiFi when promoted. After setup I decided to add a GUI by running

sudo apt install ubuntu-desktop

when I rebooted I installed Firefox and Chrome and ran a google search and they both of them worked. In settings, it says

no wifi adapter found

but when I run lspci | grep -i network, it shows a detected WiFi controller.

16
  • It is probably being controlled in netplan. Please edit your question to show the result of the terminal command: cat /etc/netplan/*.yaml Welcome to Ask Ubuntu.
    – chili555
    Commented Jul 4, 2023 at 19:33
  • Does this answer your question? My wireless/WiFi connection does not work. What information is needed to diagnose the issue?
    – waltinator
    Commented Jul 4, 2023 at 19:37
  • it says this when I run "cat /etc/netplan/*.yaml" "cat: /etc/netplan/00-installer-config-wifi.yaml: Permission denied # This is the network config written by 'subiquity' network: ethernets: enp2s0: dhcp4: true version: 2"
    – Joemy
    Commented Jul 4, 2023 at 19:41
  • no that post does not anwser my question because I have a wifi connection but it wont show up in the gooey
    – Joemy
    Commented Jul 4, 2023 at 19:43
  • What does this command result with in terminal lspci -nnk | grep -iA3 net
    – Jeremy31
    Commented Jul 4, 2023 at 19:58

2 Answers 2

2

I suggest that you back up your current netplan file:

sudo mv /etc/netplan/00-installer-config-wifi.yaml  /etc/netplan/00-installer-config-wifi.bak

Write a new one:

sudo nano /etc/netplan/01-network-manager-all.yaml

Add the following:

# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager

Netplan is very specific about spacing, indentation, etc., so proofread carefully twice.

Save (Ctrl+o followed by Enter) and exit (Ctrl+x).

Follow with:

sudo netplan generate
sudo netplan apply
sudo sudo service NetworkManager restart

Is there any improvement? It might take a reboot.

3
  • how do I know if it backed up and what do I do if I does not work
    – Joemy
    Commented Jul 6, 2023 at 18:35
  • Do you see the backup in ls /etc/netplan? If it doesn't work, you run and post the wireless script again and we troubleshoot.
    – chili555
    Commented Jul 6, 2023 at 19:45
  • thank you that worked
    – Joemy
    Commented Jul 6, 2023 at 20:47
0

When I implemented the solution offred by chili555 I got a bunch of messages like this:

Permissions for /etc/netplan/01-network-manager-all.yaml are too open. Netplan configuration should NOT be accessible by others.

Don't forget to change the permissions on the new file:

sudo chmod -c --reference=/etc/netplan/00-installer-config.yaml 00-installer-config-wifi.bak

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .