60

My eyes hurt so I thought I should check the screen refresh rate (monitor frequency), but I couldn't find it.

Where is it? (in Ubuntu 12)

1
  • If your eyes hurt, I suggest you check out the topic of color temperature correction (F.lux and redshift are two great apps for this)
    – Bernát
    Jun 10 '15 at 19:02
71

Compiz looked like it worked. But it didn't work.

So the solution to this is the following.

First we check available modes.
$ xrandr
1440x900       59.9+*   75.0
1280x1024      75.0     60.0

Then we pick the mode, including resolution and refresh rate.
$ xrandr -s 1440x900 -r 75

Or just the refresh rate
$ xrandr -r 75

Let's see if it worked
$ xrandr
1440x900       59.9+    75.0*
1280x1024      75.0     60.0

Alright. Then all you have to do is add the command to Startup Applications and be done.

7
  • 2
    I wonder why didnt some one mention this ?????? Rate 75.0 Hz not available for this size" . Its not the correct solution at all.
    – Pratik
    Feb 13 '15 at 18:21
  • 1
    @PratikCJoshi Try using a different type of cable, for example HDMI. Apr 13 '16 at 13:30
  • @PratikCJoshi You probably used xrandr -r 75.0, which may not work, while xrand -r 75 should. Even if the displayed framerate is something like 74.98 (my case) you should take the nominal value and use xrandr -r 75.
    – fsanches
    Oct 20 '16 at 2:14
  • 5
    BTW, from here: star (*) is the current mode, the plus (+) is the preferred one. Most monitors report a preferred mode to the driver. Apr 30 '17 at 22:19
  • 1
    I recently needed to use the xrandr command as follows: xrandr --output eDP-1 --mode 1920x1080 --rate 59.93 for this to work, otherwise there was no change. Check the output device from the 2nd line of xrandr output. Would be nice if there was a way without adjusting xorg.conf or adding a startup script to make this permanent. Somehow 60.01 (= the default rate) makes my eyes bleed (screen flickers in the dark areas), whilst using 59.93 doesn't (recent HP Probook).
    – 4levels
    Jun 22 '18 at 23:59
16

open your terminal and type this

sudo apt-get install compizconfig-settings-manager

then type compiz in your unity dash , it will list you compiz settings manager .Open compiz and at general options click at composite and there you have untick the detect refresh rate then you can manually set the value you want . enter image description here .

and two know allowed refresh rates for the resolution you can use xrandr

the second row are allowed refresh rates with respect to the resolutions . so by depending on resolutions you have set , you can change the refresh rate by using the above methods . enter image description here

3
  • 3
    How can I know which is the max allowed? Can't this break my monitor? Jun 7 '12 at 3:08
  • Do you really think its that simple ??? It adjusts to 60Hz on reboot no matter what value you set !!!
    – Pratik
    Feb 13 '15 at 18:20
  • WARNING: Starting compiz broke my system and forced me to reboot
    – pubkey
    May 9 '20 at 12:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.