1

I'm using the built in Gnome Remote Desktop using Wayland in Ubuntu 22.04.2 LTS (Jammy Jellyfish) and remoting using Windows 11's Remote Desktop Connection. For some reason the first time I attempt to connect to Gnome Remote Desktop after exiting, I receive an error stating: "Remote Desktop can't find the computer [server]. This might mean that [server] does not belong to the specified network. Verify the computer name and domain that you are trying to connect to." Remote Desktop Error

The weird thing is when I "ok" the error and click connect a second time, it always works immediately and no errors occur.

Here is a visual gif representation of the issue that occurs every time, you can recreate it by clicking 'x' in remote desktop connection, reconnecting and getting an error, clicking okay, and immediately being able to reconnect to the server: https://imgur.com/OyW66kK

I ran journalctl --user-unit gnome-remote-desktop.service --no-pager to try and pull some error logs and came to a few conclusions.

  1. A series of errors occur the moment I hit the close button in Remote Desktop that ends in connect transport failed.
Jun 30 18:01:23 server gnome-remote-desktop-daemon[4089]: [18:01:23:090] [4089:8877] [ERROR][com.freerdp.core.peer] - peer_recv_callback: CONNECTION_STATE_ACTIVE - peer_recv_pdu() fail
Jun 30 18:01:23 server gnome-remote-desktop-daemon[4089]: [18:01:23:090] [4089:8877] [ERROR][com.freerdp.core.transport] - transport_check_fds: transport->ReceiveCallback() - -1
Jun 30 18:01:23 server gnome-remote-de[4089]: Unable to check file descriptor, closing connection
Jun 30 18:01:23 server gnome-remote-desktop-daemon[4089]: [18:01:23:096] [4089:4089] [ERROR][com.freerdp.core.transport] - BIO_should_retry returned a system error 104: Connection reset by peer
Jun 30 18:01:23 server gnome-remote-desktop-daemon[4089]: [18:01:23:096] [4089:4089] [ERROR][com.freerdp.core] - transport_write:freerdp_set_last_error_ex ERRCONNECT_CONNECT_TRANSPORT_FAILED [0x0002000D]
  1. A series of errors occur when I attempt to reconnect the first time after exiting that ends in the connection being closed, even though it was also closed when I originally hit close previously.
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: ore.gcc] - Selected rdp encryption method: NONE
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:40:365] [4089:8769] [INFO][com.freerdp.core.connection] - Client Security: NLA:1 TLS:1 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:40:365] [4089:8769] [INFO][com.freerdp.core.connection] - Server Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:40:365] [4089:8769] [INFO][com.freerdp.core.connection] - Negotiated Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:45:893] [4089:8787] [INFO][com.freerdp.core.connection] - Client Security: NLA:1 TLS:1 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:45:893] [4089:8787] [INFO][com.freerdp.core.connection] - Server Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:45:893] [4089:8787] [INFO][com.freerdp.core.connection] - Negotiated Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:46:990] [4089:8787] [INFO][com.freerdp.core.connection] - Accepted client: client
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:46:990] [4089:8787] [INFO][com.freerdp.core.connection] - Accepted channels:
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:46:990] [4089:8787] [INFO][com.freerdp.core.connection] -  rdpdr
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:46:990] [4089:8787] [INFO][com.freerdp.core.connection] -  rdpsnd
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:46:990] [4089:8787] [INFO][com.freerdp.core.connection] -  cliprdr
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:46:990] [4089:8787] [INFO][com.freerdp.core.connection] -  drdynvc
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:46:990] [4089:8787] [INFO][com.freerdp.core.gcc] - Active rdp encryption level: NONE
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:46:990] [4089:8787] [INFO][com.freerdp.core.gcc] - Selected rdp encryption method: NONE
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:55:416] [4089:8815] [INFO][com.freerdp.core.connection] - Client Security: NLA:1 TLS:1 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:55:416] [4089:8815] [INFO][com.freerdp.core.connection] - Server Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:51:55:416] [4089:8815] [INFO][com.freerdp.core.connection] - Negotiated Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:641] [4089:8833] [INFO][com.freerdp.core.connection] - Client Security: NLA:1 TLS:1 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:641] [4089:8833] [INFO][com.freerdp.core.connection] - Server Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:641] [4089:8833] [INFO][com.freerdp.core.connection] - Negotiated Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:741] [4089:8833] [INFO][com.freerdp.core.connection] - Accepted client: client
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:741] [4089:8833] [INFO][com.freerdp.core.connection] - Accepted channels:
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:741] [4089:8833] [INFO][com.freerdp.core.connection] -  rdpdr
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:741] [4089:8833] [INFO][com.freerdp.core.connection] -  rdpsnd
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:741] [4089:8833] [INFO][com.freerdp.core.connection] -  cliprdr
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:741] [4089:8833] [INFO][com.freerdp.core.connection] -  drdynvc
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:741] [4089:8833] [INFO][com.freerdp.core.gcc] - Active rdp encryption level: NONE
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:00:741] [4089:8833] [INFO][com.freerdp.core.gcc] - Selected rdp encryption method: NONE
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:04:023] [4089:8859] [INFO][com.freerdp.core.connection] - Client Security: NLA:1 TLS:1 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:04:023] [4089:8859] [INFO][com.freerdp.core.connection] - Server Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:04:023] [4089:8859] [INFO][com.freerdp.core.connection] - Negotiated Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:801] [4089:8877] [INFO][com.freerdp.core.connection] - Client Security: NLA:1 TLS:1 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:801] [4089:8877] [INFO][com.freerdp.core.connection] - Server Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:801] [4089:8877] [INFO][com.freerdp.core.connection] - Negotiated Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:824] [4089:8877] [INFO][com.freerdp.core.connection] - Accepted client: client
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:824] [4089:8877] [INFO][com.freerdp.core.connection] - Accepted channels:
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:824] [4089:8877] [INFO][com.freerdp.core.connection] -  rdpdr
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:824] [4089:8877] [INFO][com.freerdp.core.connection] -  rdpsnd
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:824] [4089:8877] [INFO][com.freerdp.core.connection] -  cliprdr
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:824] [4089:8877] [INFO][com.freerdp.core.connection] -  drdynvc
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:824] [4089:8877] [INFO][com.freerdp.core.gcc] - Active rdp encryption level: NONE
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [17:52:11:824] [4089:8877] [INFO][com.freerdp.core.gcc] - Selected rdp encryption method: NONE
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:958] [4089:9204] [INFO][com.freerdp.core.connection] - Client Security: NLA:1 TLS:1 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:958] [4089:9204] [INFO][com.freerdp.core.connection] - Server Security: NLA:1 TLS:0 RDP:0
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:958] [4089:9204] [INFO][com.freerdp.core.conne[18:02:03:053] [4089:9204] [WARN][com.winpr.negotiate] - AcceptSecurityContext status SEC_I_CONTINUE_NEEDED [0x00090312]
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:060] [4089:9204] [WARN][com.winpr.negotiate] - AcceptSecurityContext status SEC_I_COMPLETE_NEEDED [0x00090313]
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:062] [4089:9204] [ERROR][com.freerdp.core.transport] - BIO_read returned a system error 104: Connection reset by peer
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:062] [4089:9204] [ERROR][com.freerdp.core] - transport_read_layer:freerdp_set_last_error_ex ERRCONNECT_CONNECT_TRANSPORT_FAILED [0x0002000D]
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:062] [4089:9204] [ERROR][com.freerdp.core.nla] - [nla_recv] error: -1
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:062] [4089:9204] [ERROR][com.freerdp.core.transport] - client authentication failure
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:062] [4089:9204] [ERROR][com.freerdp.core.peer] - peer_recv_callback: CONNECTION_STATE_INITIAL - rdp_server_accept_nego() fail
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:062] [4089:9204] [ERROR][com.freerdp.core.transport] - transport_check_fds: transport->ReceiveCallback() - -1
Jun 30 18:02:03 server gnome-remote-desktop-daemon[4089]: [18:02:03:062] [4089:4089] [ERROR][com.freerdp.core.transport] - BIO_should_retry returned a system error 32: Broken pipe
Jun 30 18:02:03 server gnome-remote-de[4089]: Unable to check file descriptor, closing connection
  1. Then during the second click of "Connect", two warnings occur during success (possibly unrelated to the issue) before successfully connecting.
Jun 30 18:32:27 server gnome-remote-desktop-daemon[1232]: [18:32:27:220] [1232:3756] [WARN][com.winpr.negotiate] - AcceptSecurityContext status SEC_I_CONTINUE_NEEDED [0x00090312]
Jun 30 18:32:27 server gnome-remote-desktop-daemon[1232]: [18:32:27:278] [1232:3756] [WARN][com.winpr.negotiate] - AcceptSecurityContext status SEC_I_COMPLETE_NEEDED [0x00090313]
Jun 30 18:32:27 server gnome-remote-de[1232]: [RDP.RDPGFX] CapsAdvertise: Accepting capability set with version RDPGFX_CAPVERSION_106, Client cap flags: H264 (AVC444): true, H264 (AVC420): true
Jun 30 18:32:27 server gnome-remote-de[1232]: [RDP.CLIPRDR] Client capabilities: long format names, stream file clip, file clip no file paths, can lock clip data, huge file support

I'm assuming that during the initial closing of the connection by clicking 'x' in windows remote desktop connect it is either sending an incorrect tpkt header somewhere or something is failing to close the connection that causes the 3389 port to stay occupied until another connection request (that fails) refreshes/disconnects the bugged connection, allowing the second connection attempt to go through?

Is anyone else aware of this issue, know of a fix, or have any ideas on where else to start troubleshooting for a fix?

1 Answer 1

0

Okay so figured out a solution, but not the exact cause. Running the linux computer on a wifi connection seemed to be the issue and plugging it in through ethernet has completely solved it. It seems like it has to do with the wifi drivers/settings/config either resetting or needing to be woken up after every connection. On an ethernet connection this is fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .