I followed a previous post to install dssp on Ubuntu

How to install dssp (secondary structure assignments) under 12.04?

After the installation I tried to execute dssp which was in /usr/local/bin/dssp But it gave me the following error bash: /usr/local/bin/dssp: cannot execute binary file

Also I tried to analyses some trajectory files from a simulation using the code

do_dssp -s md.tpr -f traj.xtc

But it also failed giving me the error below

Reading file md.tpr, VERSION 4.5.5 (single precision)
Reading file md.tpr, VERSION 4.5.5 (single precision)
Segmentation fault (core dumped)

Please post me a solution for this problem. Thank you!


I think your problem is that you did not write sudo chmod a+x /usr/local/bin/dssp ? (I just installed and used dssp, with the link that you provided, and it works OK)

(You should make another question for the other problem (with a better explanation and new title))

| improve this answer | |

Just updating a little bit. This is program is very easy to install in Ubuntu 14.04

fmp@lucy:~/Downloads$ sudo apt-get install dssp
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following extra packages will be installed:
libboost-iostreams1.54.0 libboost-program-options1.54.0
libboost-system1.54.0 libboost-thread1.54.0
The following NEW packages will be installed:
dssp libboost-iostreams1.54.0 libboost-program-options1.54.0
libboost-system1.54.0 libboost-thread1.54.0
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.

Setting up dssp (2.2.1-1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.3) ...

You have to call it with mkdssp!! Examples:

To calculate the secondary structure for the file 1crn.pdb and write the result to a file called 1crn.dssp, you type:

mkdssp -i 1crn.pdb -o 1crn.dssp
| improve this answer | |

This is bug. I was using do_dssp with previous versions of GROMACS. It did not run when it was upgraded to version 4.5.5. Somebody please upload GROMACS 4.6 in UBUNTU software center. I believe this issue had been fixed in GROMACS 4.6. see this link.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.