I have just installed 12.04 and plugged in E160 and nothing happened - modem doesn't mount.

I have found this solution :

Ubuntu does not mount some Huawei devices due to bugs, problems etc. See if these work:

1st option:

Connect the USB modem.

After 10 seconds, type this in a terminal window:


The output will be like this:

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 004: ID 12d1:140b Huawei Technologies Co., Ltd. 
Bus 004 Device 002: ID 413c:3016 Dell Computer Corp. Optical 5-Button Wheel Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 005: ID 0b97:7762 O2 Micro, Inc. Oz776 SmartCard Reader
Bus 002 Device 004: ID 413c:8103 Dell Computer Corp. Wireless 350 Bluetooth
Bus 002 Device 003: ID 0b97:7761 O2 Micro, Inc. Oz776 1.1 Hub
Bus 002 Device 002: ID 413c:a005 Dell Computer Corp. Internal 2.0 Hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The device is a Huawei modem, so let's look at the output. The relevant entry is:

Bus 004 Device 004: ID 12d1:140b Huawei Technologies Co., Ltd

Hence, you must type:

sudo modprobe usbserial vendor=0x12d1 product=0x140b

2nd option

Download usb-modeswitch and usb-modeswitch-data packages from packages.ubuntu.com.

Install them through the command:

sudo dpkg -i usb-modeswitch*.deb

3rd option

Try a combination of both.

but with no result. The modem is still not detected. I've tried to add a new connection but the system can't see my device in setup dialogue.

Also I have noticed that when I open eg. terminal and try to type sth, the system freezes for a while..

Thanks for help!


Can you try wader-core? It should definitely support the Huawei E160.

sudo apt-get install wader-core

And then try a reboot.

| improve this answer | |
  • I download wader-core by windows, but i cant install it because modem-manager is installed. I've tryed sudo apt-get remove modem-manager but says there is no modem-manager installed.. – Matt Jun 7 '12 at 7:54

I know this question is a bit old but I have had the same problem and hopefully can help out someone else.

My modem is a Huawei E160 on Optus.

I first started Network Manager > Edit Connections, and created a new Mobile Broadband profile, filling in info as required.

After creating the profile, Edit and click on PPP Settings and make sure ONLY PAP is listed under Authentication.

At this point, my modem was recognized intermittently (like 1/1000 times) by Network Manager. However, when I typed:


...into the terminal, the device was always there.

After a LOT of searching threads I found this solution (I can't find the thread again, and will add the link if I do). It seems the problem is that the modem is being seen as a mobile storage device (although it doesn't appear as a disk on the Home Folder) and not as a modem.

  1. Type into the terminal:

    sudo -H gedit /etc/modules
  2. Add the following line:

    usbserial vendor=0x12d1 product=0x1003

    NOTE: for you the numbers may be different, you can find them by typing lsusb and noting the two numbers after ID that are separated by a :. The first one is the vendor ID and the second is the product ID.

  3. Now save and exit and reboot WITH THE MODEM PLUGGED IN.

It should now appear. There may be other methods for getting it to work hot-plugged but I'm not aware as yet.

| improve this answer | |

I recommend sakis3G for connecting usb modem. So try it once.

  1. plug your modem
  2. open sakis3G (it is not pre-installed so you have to first installed on your system)
  3. select "connect to 3G"
  4. select "USB modem" as modem type
  5. select your modem from list
  6. add APN in the space provided.
  7. give anything as username and password when sakis3G asked for.

Now it will try to connect and when connection is establish it will show a dialog box

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.