I have a Toshiba USB floppy drive that I need to use under Ubuntu. When I connect it, and insert a floppy disk in it, I do not see anything mounted under Ubuntu 10.10.

I was suspecting the hardware and/or the floppy disk to be defective, and so I tested the floppy disk as well as the floppy drive itself under Windows XP, and everything was just fine.

I was able to find the following instructions:

  • Add the following line to the /etc/modules file:


  • Enter the following shell commands:

    mkdir /media/floppy
    mount -t vfat /dev/sdc /media/floppy -o uid=1000

This will mount the floppy, but I would like this to happen automatically, so when I connect the drive to the USB port, it automatically mounts the floppy.

How can I make this work? Or does Ubuntu only work with internal Floppy drives?

  • Could you please look at /var/log/messages if the device was correctly detected? use paste.ubuntu.com to show us any relevant info. Thanks! – crncosta Nov 24 '10 at 13:22
  • This will help you look for which logs to paste: askubuntu.com/questions/14008/… – Jorge Castro Nov 24 '10 at 13:53
  • please show the output of lsusb. – tinhed Nov 24 '10 at 14:49
  • 1
    I've had this too with my USB floppy and my motherboard floppy as well in 10.04. The floppies show in Disk Utility and I can write to them (say, with dd) but they don't mount. – Broam Nov 29 '10 at 17:37

The following procedure worked instantly on Ubuntu 12.04:

The df command shows that /dev/sdd show that d the last assigned drive in use. I need to know this to find the next available one, which is used in the subsequent sudo mount ... command. In my case, the next drive will be /dev/sde .

You will need to determine the correct drive for your own system. For example, you might have /dev/sda, or sdb, or sdc.

So, first, to see the drive information: df

Next, run mkdir and mount :

 mkdir /mt/ee1

 sudo mount -t vfat /dev/sde /mt/ee1 -o uid=1000

For automatic execution at boot time, I normally use Perl scripts, which detect and adapt automatically and give stable names to the partitions.

I do not need this at this point of time for floppies, and therefore I didn't optimize it. Perhaps the command "mount ..." is not optimal....)

A more general but a bit primitive solution would be to create a bash/batch file with multiple lines as above with sudo... , with the several probable possible variants /dev/sd... on the specific PC.

Then there might be a call of this file in the settings of "Startup Applications". I did not test this.

In addition, this does not deal with the aspect of removing or inserting a different floppy disk. This could be done in some automatic or at least semi-automatic manner....

I do not know if the way above is optimal. I just wanted to add helpful information, after having settled my own problem with the preceding answers.


On my older systems with built-in floppy drives, the drive is designated as /dev/fd0. Unfortunately, later releases of Ubuntu do not automatically mount these drives, nor do they create a directory in /media for it.

To mount my drive, I first have to create a directory to mount it in, /media/floppy. Then I can mount it using sudo mount /dev/fd0 /media/floppy.

  • When I try the commands, the mount command responds: <p> mount: special device /dev/fd0 does not exist<p> I also tried the /dev/sdb1 device name instead (since this is a USB device, after all). Same answer. With the lsusb command, I get to see:<p> Bus 003 Device 002 : ID 0644:0000 TEAC Corp. Floppy. – jfmessier Nov 29 '10 at 15:17

Make sure there is a floppy disk in the drive or else there is nothing to mount! Don't sudo mount or else you can only access with root privileges.

First, to see the drive information, run df.

On my system with one HD the floppy appears as sdb (sda was the hard drive)

Then to mount:

udisks --mount /dev/sdb --mount-fstype=vfat


fred@Ubuntu1:~$ udisks --mount /dev/sdb --mount-fstype=vfat
Mounted /org/freedesktop/UDisks/devices/sdb at /media/MM259_32BIT
fred@Ubuntu1:~$ df
Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/sda1      152030356 9315352 134992252   7% /
udev              890692       4    890688   1% /dev
tmpfs             360384     856    359528   1% /run
none                5120       0      5120   0% /run/lock
none              900956     292    900664   1% /run/shm
/dev/sdb            1424    1397        27  99% /media/MM259_32BIT

I wrote a little script that auto-detects the drive id when you run it, takes some of the donkey work out. This isn't perfect because it is possible it will detect the wrong thing (note the comments), but it seems to work most of the time for me:

# mount a usb floppy drive on /media/floppy
# NB we _assume_ other drives, e.g. internal hdd and usb devices will have been
#    automatically mounted. most of the time this will be true, but there are
#    no checks in place if this is not so.

# make sure the mount point exists
if ! [ -e /media/floppy ]; then
    sudo mkdir /media/floppy

# get a list of the available disks
disks=($(udisks --enumerate |\
         sed 's_/org/freedesktop/UDisks/devices/__' |\
         grep 'sd'))

#get a list of mounted devices
mounts=($(mount | grep '/dev/sd' | awk '{print $1}'))

# work out which disk is not mounted (first one found - assume this is the fdd)
for disk in "${disks[@]}"; do
    if ! for mount in "${mounts[@]}"; do echo $mount; done | grep -q $disk 
        sudo mount -t vfat /dev/$disk /media/floppy -o uid=1000
        echo fdd /dev/$disk mounted on /media/floppy

To do a clean unmount:

# unmount a floppy drive mounted on /media/floppy

sudo umount /media/floppy
sudo rmdir /media/floppy
echo fdd unmounted from /media/floppy

If the floppy is not showing up in the mount list there might be issues with Ubuntu detecting floppy drives. I think we need more information regarding the problem before we can theorize about the issue and it's resolution. Since this is a USB device, you can use the lsusb logs to see if the device has been detected by Ubuntu. A good place to look for dealing hardware detection problems would be - https://wiki.ubuntu.com/DebuggingHardwareDetection

  • Ubuntu has not auto-detected any floppy drives for 2-3 releases already. – charlie-tca Nov 30 '10 at 0:00

You're going to need to leave the drive plugged in - Ubuntu will happily reassign /dev/sdc or /dev/sdd to the drive next time you plug it in, as that's what happens to mine.

Since the drive won't have a file system on it, you may not be able to get a UUID to uniquely identify the filesystem.


As shown at http://ubuntuforums.org/showthread.php?t=1641104 the easiest way to mount it is:

  1. Identify the drive's device,
sudo df
udisks --enumerate

for example, mine was /dev/sdc , but just to make sure:

udisks --show-info /dev/sdc
  1. Mount it with the udisks command
sudo udisks --mount /dev/sdc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.