Most recent Ubuntu 12.04 seems to be quite nice and Unity (3D/2D) works fine for me, however not on my old Acer Aspire One any more.

There was a times, when I switched from Windows XP to Ubuntu and was happy about system looks, effects and speed... now I attend to think that XP was really great comparing with 12.04.

I have found similar questions here but no reasonable answer: how to lower CPU usage for Unity (3D/2D) and memory consumption for Ubuntu 12.04.

With new interface I could not find how to disable background services...

It's Linux, it's should be the way to optimize without buying new PC... Please share your recipe!

5 Answers 5


I know this is an old question, but I had similar problems on my Samsung netbook and maybe the described steps will be useful to someone. My netbook is an old machine and Ubuntu 12.04 was too slow to be useful. I tried several tweaks, which improved things, but not enough.

I didn't feel like replacing Ubuntu with Lubuntu and then installing all the software that I like in Ubuntu.

So I did the following:

I really like Unity and I use it on my desktop computer. And while the above doesn't allow you to use some cool features such as the global menu and HUD, I find it's a very good compromise. Everything now works really, really fast.

  • One more thing that I forgot, sorry: when installing the LXDE core on top of Ubuntu 12.04 all the icons disappear (at least that is what always happened to me). This can be corrected by installing LXAppearance, running it and selecting one of the listed icon themes. (sudo apt-get lxappearance)
    – Nikec
    Dec 2, 2012 at 13:58

First thing to do to lower memory consumption is to stop using applications that are memory hogs. The applications that I had to switch away from were Banshee, Evolution, Liferea, and Tomboy. The applications which I switched to respectively were Rhythmbox, Thunderbird, Google Reader and none (graduated from school so no longer need a note taking application).

Second thing to do is to make Firefox more friendly. In Preferences » General uncheck the Don't load tabs until selected checkbox and set the When Firefox starts option to Show my windows and tabs from last time. Whenever my computer gets slow, I close Firefox and re-open it which causes all tabs to not be loaded except for the one that I am currently using. If you have flash installed then the Flashblock plugin is necessary. Firefox tabs in the background that are using flash are very demanding and Flashblock helps you stay aware when Flash is in use. AdBlock will also help keep Firefox more resource friendly if you are desperate.

That is all the advice that I have for you. I have found the Unity 3D interface to be very usable on my older netbook (Intel Atom N270 with GMA 950). My computer does get slow at times but that is almost exclusively a Firefox problem but I tend to open up a lot of tabs so that is easily fixed.


You can try zRamswap which is a program that create a compressed RAM block and make it act as a swap disk. Basically, this program increase performances by using a small amount of RAM as a swap area (instead of swap disk which is slow compared to RAM).

You can install this program by adding this ppa to your software sources:

 sudo apt-add-repository ppa:shnatsel/zram
 sudo apt-get update
 sudo apt-get install zramswap-enabler
  • Please note that with precise pangolin there's no longer the need for that ppa. Simply type sudo apt-get install zram-config in a terminal, wait for the installation to finish and reboot. There's no need for further configuration.
    – FuzzyQ
    Jun 30, 2012 at 14:31

I would install Lubuntu or Xubuntu as it has lower requirements. In a terminal, execute:

sudo apt-get install xubuntu-desktop


sudo apt-get install lubuntu-desktop

I personally use Lubuntu, but you can use either.

  • 5
    Doesn't really answer the question though.
    – nikhil
    Jun 7, 2012 at 10:57
  • 100% I'd like to have Ubuntu look and feel on my netbook. I believe there is some capacity in it to run 12.04 smoothly. I just haven't found it (yet :) Jun 7, 2012 at 16:02
  • Using LXDE to make your computer faster is like replacing your car with a skateboard to save on gas. You're not wrong...but this is not a solution anyone wants.
    – Cerin
    Jul 10, 2016 at 14:52

I am using a pretty smooth 14.04 on my samsung nc10 plus. maybe it will help you out on 12.04 too:

First of all i deactivated the effects in unity using unity tweak tool and compiz config:

sudo apt-get install unity-tweak-tool compizconfig-settings-manager

I also set the swap usage to a more reasonable level:

open sysctl.conf gksudo gedit /etc/sysctl.conf and add vm.swappiness=10 to the file, then reboot.

Last of all I deleted all unity-lenses exept the applicaion- and the files-lense:

sudo apt-get autoremove --purge unity-lens-music unity-lens-video unity-lens-photos unity-lens-gwibber unity-lens-shopping 

After doing that, my netbook runs pretty smooth and good runing unity. If you are only concerned abou the look, try installing the gnome flashback session:

sudo apt-get install gnome-session-flashback

That's all I can do to provide some help. Cheers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.