I'm trying to install openvpn on Ubuntu. Following these steps, I ran the following commands as root user in my terminal:

apt update
apt upgrade
apt install ca-certificates wget net-tools gnupg
wget -qO - https://as-repository.openvpn.net/as-repo-public.gpg | apt-key add -
echo "deb http://as-repository.openvpn.net/as/debian focal main">/etc/apt/sources.list.d/openvpn-as-repo.list
apt update

So far so good. Then I tried running

apt install openvpn-as

which started off well but ended in these lines:

Setting up openvpn-as (x.xx.x-xxxxxxxx-Ubuntu20) ...
Automatic configuration failed, see /usr/local/openvpn_as/init.log
You can configure manually using the /usr/local/openvpn_as/bin/ovpn-init tool.
Created symlink /etc/systemd/system/multi-user.target.wants/openvpnas.service → /lib/systemd/syst
Setting up python3-twisted (22.1.0-2ubuntu2.3) ...
Processing triggers for man-db (2.10.2-1) ...
Processing triggers for libc-bin (2.35-0ubuntu3.1) ...

Please would someone advise me on the next steps to take in the installation. How does one go about manually configuring openvpn using the ovpn-init tool?


You must log in to answer this question.

Browse other questions tagged .