2

My Wifi speed is significantly lower on Ubuntu 22.04 than on windows. Iv'e tried all previous solutions as suggested in these: Wifi is slow and unstable on ubuntu 20.04 dual boot (DELL XPS-L502X)
wifi on ubuntu works slower than wifi on windows for my laptop
https://itsfoss.com/speed-up-slow-wifi-connection-ubuntu/

Here is the output for lshw -C network:

WARNING: you should run this program as super-user.
  *-network                 
       description: Wireless interface
       product: Cannon Lake PCH CNVi WiFi
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       logical name: wlp0s20f3
       version: 10
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.19.0-43-generic firmware=46.fae53a8b.0 9000-pu-b0-jf-b0- ip=192.168.0.248 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:16 memory:a4410000-a4413fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: enp7s0
       version: 25
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.19.0-43-generic firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:17 ioport:3000(size=256) memory:a4204000-a4204fff memory:a4200000-a4203fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

for ifconfig:

ifconfig wlp0s20f3
wlp0s20f3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.248  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::4a02:4740:bb5a:5e98  prefixlen 64  scopeid 0x20<link>
        ether d0:ab:d5:22:ce:0a  txqueuelen 1000  (Ethernet)
        RX packets 293424  bytes 378162085 (378.1 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 121545  bytes 19402081 (19.4 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Kernel: Linux 5.19.0-43-generic

changing the wifi.powersave to 2 doesn't help either. Nor does rfkill unblock all.

Can someone please help in debugging and fixing the issue.

[Edits]: Output for grep '[[:alnum:]]' /sys/module/iwlwifi/parameters/* as requested by @Jeremy31

grep '[[:alnum:]]' /sys/module/iwlwifi/parameters/*
/sys/module/iwlwifi/parameters/uapsd_disable
3

/sys/module/iwlwifi/parameters/swcrypto
1

/sys/module/iwlwifi/parameters/remove_when_gone
N

/sys/module/iwlwifi/parameters/power_save
N

/sys/module/iwlwifi/parameters/power_level
0

/sys/module/iwlwifi/parameters/nvm_file
(null)

/sys/module/iwlwifi/parameters/led_mode
0

/sys/module/iwlwifi/parameters/fw_restart
Y
/sys/module/iwlwifi/parameters/enable_ini: Operation not permitted (os error 1)

/sys/module/iwlwifi/parameters/disable_11ax
N

/sys/module/iwlwifi/parameters/disable_11ac
N

/sys/module/iwlwifi/parameters/bt_coex_active
N

/sys/module/iwlwifi/parameters/amsdu_size
0

/sys/module/iwlwifi/parameters/11n_disable
1
5
  • Please edit to add results from terminal for grep [[:alnum:]] /sys/module/iwlwifi/parameters/*
    – Jeremy31
    Jun 10, 2023 at 17:50
  • @Jeremy31 added. Is there something more needed? Can the issue be fixed?
    – Manan Shah
    Jun 10, 2023 at 18:43
  • Find where you set 11n_disable=1 and change it to 11n_disable=8 and reboot
    – Jeremy31
    Jun 10, 2023 at 18:50
  • Absolutely amazing!! This solved the issue. What was causing the link speed to drop? It is almost 10x now. Thanks a ton.
    – Manan Shah
    Jun 10, 2023 at 19:02
  • 11n_disable=1 slows them down, 11n_disable=8 enables aggressive TX and it usually helps a lot
    – Jeremy31
    Jun 10, 2023 at 19:04

1 Answer 1

2

Find where 11n_disable=1 is set and change it to 11n_disable=8. In my case I did:
sudo nano /etc/modprobe.d/iwlwifi.conf and made the edit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .