1

I installed the icaclient (it's a client for Citrix) a while back. I don't exactly remember what I did to get it working but it was enervating. I had to install some old packages not even avaiable for ubuntu (12.04) and in the end I used some stuff from old rpms.

Anyway the client is more or less working now but I always get a dpkg error when installing or updating something. The (translated) error message is something like:

dpkg: Error while processing icaclient:i386 (--configure): subprocess installed post-installation-script return errorcode 2

I just want to tell dpkg to ignore this or remove this post-install-script but I don't know how.

Thanks!

0

First, please try the following in terminal:

sudo aptitude update
sudo aptitude -f install

If it does not work, then you may want to try:

sudo dpkg --force all --remove

If these are not helping you than I have bad news. There is no way to skip post-install scripts. The official Debian policy is to edit the script to return a non-terminal error, or fix the script.

| improve this answer | |
  • Ok the last command worked when I added icaclient:i386 to the remove option. – Photonics1 Jun 6 '12 at 10:04
8

Just install version 12.0 instead of 12.1. It is (still) available on Citrix site (http://www.citrix.com/site/SS/downloads/details.asp?downloadId=2316611&productId=1689163) and works just fine.

Or you can extract the package:

dpkg -x icaclient_12.1.0_amd64.deb /some/folder
mkdir /some/folder/DEBIAN
dpkg -e icaclient_12.1.0_amd64.deb /some/folder/DEBIAN
vi /some/folder/DEBIAN/postinst

In line 2648, change the text between double quotes ("i[0-9]86") for "[0-9,x]86" an then run the following:

dpkg -b /some/folder

It will correct the bug in the postinst script that tries to figure out the architecture of your processor. The 'dpkg -b /some/folder' will then recompile (build) the package. All you need now is to install the recompiled package, which will be named after the folder you used to extract it. I just don't know why Citrix haven't done it yet, for it is a relatively old bug, and with a very simple solution.

If you are not interested in doing the dirty job, just download the version I corrected from https://dl.dropbox.com/u/3207848/icaclient_12.1.0_amd64.deb.

Hope I helped!

| improve this answer | |
  • To confirm, Igor's .deb file just solved this issue for me. Thanks – OYRM Sep 11 '12 at 15:10
1

Worked for me as well, but I used the 32bit client on my 64bit system.

icaclient-12.1.0_i386.deb

Procedure is the same.

| improve this answer | |
  • Which solution worked for you? On which architecture? – Chris Jul 23 '13 at 19:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.