I have recently had windows XP die on one of my machines, and have installed Ubuntu. The OS works great, except for installing the Xerox Phaser 3160N printer.

The OS can find and install the network printer, but when I print a test page, it tells me

Internal Error – Please use the correct driver.

I have the correct drivers, as your support team have sent me the link but I cannot install these drivers to run the printer.

These are the instructions from the on-line guide for installing on a Linux machine:

  1. Make sure that the machine is connected to your network and powered on. Also, your machine’s IP address should have been set.
  2. Insert the supplied software CD into your CD-ROM drive.
  3. Double-click CD-ROM icon that appears on your Linux desktop.
  4. Double-click the Linux folder.
  5. Double-click the install.sh icon.
  6. The Xerox Installer window opens. Click Continue.
  7. The Add printer wizard window opens. Click Next.
  8. Select Network printer and click Search button.
  9. The Printer’s IP address and model name appears on list field.
  10. Select your machine and click Next.

I get as far as step 5, and step 6 never happens, if it did, it would be very easy from there.

There are options to add additional software to Ubuntu, however it does not recognize the installation CD as valid when I try to add it as a source.

Any ideas on how to fix this?

2 Answers 2


I am definitely no expert on the issue but here is how I solved the exact same problem:

  • Install the printer in Ubuntu with its default settings. The printer is identified as Xerox 3160.

  • Go to Printer Settings and right click on the printer Xerox 3160, then click Properties.

  • Press the Change button near Make and Model. On the next screen while "Select printer from database" is selected, scroll down to "Xerox" in the below list if it's not selected already, then click Forward.

  • Now you should see that Phaser 3160 is recommended to you. But your printer is phaser 3160N. So select phaser 3160N and choose the recommended driver for 3160N on the right side. Then click Forward, as before.

  • Now you are on the last page. Choose "Use the new PPD as is" option and apply. Try to print a test page.

So you don't need to get any additional driver which is not in Ubuntu already. I assume the problem is Ubuntu was not able to distinguish 3160N from 3160. Maybe this is a bug to report.

Please post a comment if this solved your case also.


The default Ubuntu drivers didn't work for me (gave the same error message as above). I passed stage 5 by dropping to command line, and running sudo install.sh.

It logged me out the first time, but worked the second time.

There is no 3160N option, I selected the 3160 driver, and now have a successful test page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.