Our municipal library sends a *.acsm file by mail when we borrow a e-book, but I'm fed up with having to bother my wife to use her Windows account and we must reboot 'tween nix and doze. Adobe digital editions needs Wine and .Net35SP1. So Wine is installed, but the .Net35SP1 installer (dotnetfx35setup.exe) does not connect to download the needed files. Is the server down or is there another and easier way to install ADE? I've been trying all weekend.


1 Answer 1


Download ACSM files in Linux - without using Adobe Digital Editions!

There are a few limitations, but nothing too serious:

  • Only ePub is supported.
  • No PDF Command line only.
  • Alpha quality software. It works - but is a bit finickity

You can compile the code yourself, but I just downloaded the pre-built binaries.

On Ubuntu needed to sudo apt install libzip-dev

Once you've unzipped the download, cd into it and run:



./adept_activate -u [email protected] -p SuperStrongPassword

Use the same credentials as you do in Adobe Digital Editions. You can just use the -u flag and type your password in at the prompt - but I couldn't get that to work. The -p flag worked fine.

After a few seconds, you'll see:

[email protected] fully signed and device activated in /home/you/libgourou_utils_0.3.1/./.adept

Then run:

./acsmdownloader -f whatever.acsm

After a few moments, you'll see:

Created whatever.epub

That's it! Your file is downloaded and you can read the ePub.

Note: If you try to download a PDF, you'll get an error saying:

Exception code : 0x5007
Message : whatever.epub

You can rename the file back to .pdf, but it will still be encrypted.

source: Download ACSM files in Linux - without using Adobe Digital Editions!

  • 1
    I also had to do ln -s libgourou.so libgourou.so.0.8.1 in the downloaded directory.
    – Jos
    Jun 4 at 21:27
  • download and conversion to epub worked fine. But my e-reader tels me to authorize the e-book with ADE. So I do ''adept_remove -f my_e-book.epub'' and I get ''invalid zip file''
    – Rooman
    Jun 5 at 19:49
  • I have saved Adobe credentials
    – Rooman
    Jun 5 at 19:51
  • @Rooman try to convert by this ebook.online-convert.com/convert/epub-to-pdf Jun 5 at 20:47
  • @Talaat, tried that and got a conversion error with no details., all very strange.
    – Rooman
    Jun 7 at 18:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .