I am a bit confused as to where I should put externally downloaded plugins. I have tried putting them in:

  1. /usr/share/gedit/plugins
  2. ~/. Local/gedit/plugins
  3. ~/. Gnome2/gedit/plugins
  4. /usr/lib/gedit/plugins

The way I have checked whether the plugins show up or not is going to Edit -> Preferences -> Plugins and looking for the ones I have downloaded (clickconfig, gedit-developer-plugins-...). Since I do not see any new plugins appearing, I have to assume that I am doing something wrong.

None of these have worked. I am a bit tired of polluting my system. It's probably my own fault as it's written somewhere I have not thought to look. Please let me know how to add external plugins to Gedit properly. I am running Ubuntu 11.10. My Gedit version is 3.2.3


I am still not able to solve this problem. I have tried the following folder now as well, and it hasn't worked:

~/. Config/gedit/plugins


I am trying to install the plugins in "gedit-developer-plugins" as well as the "clickconfig" plugin.


4 Answers 4


First, I'll answer the question about the specific plugins. gedit-developer-plugins Install gedit-developer-plugins is available in the official Ubuntu archive, and I'd suggest installing it from there. clickconfig, on the other hand, unfortunately does not seem to have been ported to to Gedit 3 and is not compatible.

More generally, for Gedit 3 (which is in Ubuntu 11.10 and above) local plugins should be installed to ~/.local/share/gedit/plugins The .plugin file must be in that exact directory, sub-directories are not scanned. For instance, here's the file layout of mine:

$ tree ~/.local/share/gedit/plugins/
├── markdown-preview
│   ├── __init__.py
│   ├── __init__.pyc
│   └── locale
│       └── fr
│           └── LC_MESSAGES
│               └── markdown-preview.mo
├── markdown-preview.plugin
├── reSt-preview
│   ├── __init__.py
│   └── __init__.pyc
└── reSt-preview.plugin
  • 4
    Do you know whether it still works with Ubuntu 14.04/Gedit 3.10.4? Because for me, your solution doesn't work. Interestingly, the folder ~/.local/share/gedit/plugins/ didn't even exist, although Gedit has some plugins activated. Did they change something?
    – MERose
    Dec 4, 2014 at 16:31

From the official docs on the gedit website, the folder is: /home/username/.local/share/gedit/plugins. If this folder does not exist, you will have to create it

  • Worked for me in Ubuntu 16.04 LTS. I had to create the folders as per the hierarchy mentioned and copy my plugin's .plugin & .py files into that directory. Mar 27, 2018 at 5:51



Worked for me in 11.10.

Im now using


in 12.04. Don't ask me why..

  • Sorry, this did not work for me. Jun 5, 2012 at 22:01
  • Some plugins are not compatible with gedit3. If it doesnt mention gedit3 on the web page or README, it's probably not.
    – user55822
    Jun 5, 2012 at 22:11

I am using Ubuntu 22.04 LTS. I looked for everywhere then I found it in


I didn't expect it there too. Do look there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.