I was using Ubuntu 21.10 (and stuck on that) on a dual boot with windows 10. The graphic card then was working perfectly. So I made a fresh install of Ubuntu and went for the LTS, though I'd remove windows as I wasn't using it anymore. But since the fresh install, the graphic card won't work correctly (or at all).

I have a NVIDIA Geforce GTX 1650.

I installed differents drivers, now I'm back with the 530 and my graphic card isn't detected anymore. I've run these commands with the results.

sudo apt install linux-generic

Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait Lecture des informations d'état... Fait
linux-generic est déjà la version la plus récente ( 0 mis à jour, 0 nouvellement installés, 0 à enlever et 26 non mis à jour.

-->No new updates to do.

dkms status

--> Doesn't return anything


ERROR: A query to find an object was unsuccessful

(nvidia-settings:6465): GLib-GObject-CRITICAL **: 11:40:58.959: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:6465): CRITICAL **: 11:40:58.961: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed

ERROR: nvidia-settings could not find the registry key file or the X server is not accessible. This file should have been installed along with this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text. Please see the README for possible values and descriptions.

cat /var/log/gpu-manager.log

log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/5.19.0-42-generic/kernel
Looking for nvidia modules in /lib/modules/5.19.0-42-generic/kernel/nvidia-530-open
Found nvidia.ko module in /lib/modules/5.19.0-42-generic/kernel/nvidia-530-open/nvidia.ko
Looking for amdgpu modules in /lib/modules/5.19.0-42-generic/kernel
Looking for amdgpu modules in /lib/modules/5.19.0-42-generic/updates/dkms
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? no
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? yes
Is amdgpu kernel module available? no
Vendor/Device Id: 10de:1f0a
BusID "PCI:1@0:0:0"
Is boot vga? yes
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Does it require offloading? no
last cards number = 1
Has amd? no
Has intel? no
Has nvidia? yes
How many cards? 1
Has the system changed? No
Takes 0ms to wait for nvidia udev rules completed.
Single card detected
Nothing to do

I'm a bit lost as to what I can do to make it work. Right now I have the driver installed, but the card isn't detected by my system. And when I used the X.Org driver the card was detected, but not working.
Can anyone help me find a way to make this work ?

Thanks in advance !

2 Answers 2


I ran same commands and nothing is working. If you haven't tried it (but very likely you have) go to the software and updates and try to update from there I was able to run it and after a few restarts everything seems to be ok.

FYI: it might boot u to Xserver drivers after the first restart so you may have to do another after that.


My solution. Kernel Ubuntu 22.04.2 LTS nvidia RTX3070 - FIX install Kernel 5.19.5 (I first installing 325 (all normal working) then, I installing driver 535, installation failed, black screen, force to restart the PC) and 535 working. 👍.

  • The black screen is caused by installing the NVIDIA binary Xorg driver (xserver-xorg-video-nvidia-535). Rebooting solves this problem.
    – karel
    Jul 14 at 1:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .