I have wireless Internet access and it worked well on Ubuntu 12.04 LTS until today, when I installed updates from the Update Manager. After the reloading of the computer the sign of Internet disappeared and the Internet connection stopped working.

I went to the Network section of the System settings and got such a message:

The system network services are not compatible with this version.

ping gives the result Network is unreachable.

The solution offered by drewski22785 below have solved my problem!

Thanks to everyone who gave advices!

3 Answers 3



I had the same issue, luckily I was able to figure out a fix. There appears to be an issue with the latest update of Network Manager. If you open the Ubuntu Software Center, go to History, search the keyword "Network" and you will probably see "network-manager (,".

If you see this then you have the same problem as I did. The solution is to downgrade to version 3: Search in Google "ubuntu network-manager package" and select the ubuntu.com link, then scroll down the page to "network-manager-dbg" select the precise (debug) ubuntu3 version.


Download the 4 related packages for your system (amd64 or i386):

  • network-manager (=

    • network management framework (daemon and userspace tools)
  • libnm-util2 (=

    • network management framework (shared library)
  • libnm-glib4 (=

    • network management framework (GLib shared library)
  • libnm-glib-vpn1 (=

    • network management framework (GLib VPN shared library)

Install each of them using the command sudo dpkg -i FILENAME.

Restart your computer and that should fix your problem!

  • Thank you very much, Drewski! I did what you said and it solved my problem! Commented Jun 12, 2012 at 11:33
  • oh, +1 for you @drewski22785, I followed and got my WIFI working now. And this is fresh brand new installation (12.04) - wifi was working during installation but after installation (and/or updates) it suddenly is not working. After all the steps above, I used wicd to configure my WIFI.
    – Peter Teoh
    Commented Oct 13, 2012 at 12:20

Not sure about getting the tools working, but to get the network working as a workaround in the mean time you can try this.

Press Alt+F2 or open a Terminal window and run the following command:

gksu gedit /etc/network/interfaces

Add in here:

iface wlan0 inet dhcp
wpa-ssid enteryourssidhere
wpa-psk enteryourpassphrase

Save the file and close, then run the following commands in Alt+F2 or the Terminal:

sudo ifup wlan0
sudo dhclient wlan0

This presumes you are using private WPA/PSK.

This won't solve your long term problem but may get you connected at least.

  • I tried an ethernet cable to conect to internet and I have the same problem as when I try wireless. my /etc/network/interfaces didn't help... and the network service is not compatible anymore with that version ... Commented Jun 6, 2012 at 9:18
  • Ping gave new result today: Ping ( 56(84) bytes of data. From icmp_seq=1 Destination Host Unreachable Commented Jun 10, 2012 at 20:49

OK, in a terminal, try the output from the commands ip add and ip route, and show us the context of /etc/network/interfaces.

The output from lsmod might also be useful.

  • ip add: 1: lo: LOOPBACK,UP,LOWER_UP mtu 16436 qdisk noqueue state UNKNOWN link/loopback 00.00:00:00:00:00 brd 00:00:00:00:00:00 inet scope host lo inet6 ::1/128 scope host valid_lft foreverpreferred_lft forever 2:eth0: BROADCAST,MULTICAST mtu 1500 qdisk noop state DOWN qlen 1000 link/ether f4:6d:04:81:89:23 brd ff:ff:ff:ff:ff:ff Commented Jun 6, 2012 at 22:01
  • 3: wlan0: BROADCAST,MULTICAST mtu 1500 qdisk noop state DOWN qlen 1000 link/ether 48:5d:60:ad:1e:c6 brd ff:ff:ff:ff:ff:ff Commented Jun 6, 2012 at 22:04
  • Anders, hoppas du kan hjälpa mig! Commented Jun 6, 2012 at 22:13
  • /etc/network/interfaces: auto lo iface lo inet loopback auto eth0 iface eth0 dhcp Commented Jun 10, 2012 at 20:30
  • ip route: default dev wlan0 scope link metric 1003 dev wlan0 proto kernel scope link src Commented Jun 10, 2012 at 20:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .