I am trying to install ubuntu 12.04 from a usb side by side with windows 7. My hard drive already had 3 partitions by window:

  • sda1 (1.8GB) for system

  • sda2 (700 GB) for windows

  • sda3(16GB) for windows recovery.

    I shrunk windows partition to 200GB and made a new extended partition within which sda5 (10GB) is linux-swap and rest is sda6 for linux(ext4). The installation runs fine until the end when it says "grub-install dev/sda6 failed. I tried to give it an option to install grub in dev/sda but it doesn't work. Please help.

  • could you check whether the disk is configured as basic or dynamic ? run diskmgmt.msc in windows and look below the disk name (Disk 0). [Some information will look like Disk 0 Basic 990GB Online]
    – Web-E
    Jun 5 '12 at 14:48
  • Thanks for your response. Sorry, I am at work right now and can't get on my laptop until the evening!! I will post these info asap.
    – Santosh
    Jun 5 '12 at 15:46
  • Did you try the grub-install on dev/sda2 in your case? What's in sda1? "for system" what does it means? Jun 5 '12 at 16:47
  • You may be experincing this bug bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/976027
    – Enkouyami
    Jun 5 '12 at 17:14
  • @JulienChau sda1 is possibly created by windows 7 to accommodate windows recovery environment.It contains windows boot manager. installing @ sda2 will fail as well.
    – Web-E
    Jun 5 '12 at 17:24

As mentioned in comment

I deleted the partition that Ubuntu was installed in, redid the partitioning, reinstalled the Ubuntu. This time instead of choosing the recommended option to "install side by side with windows", I chose the third option to do the partition myself.

Chose /dev/sda for grub-install. The installation was seamless. I booted to both windows and linux few times with no difficulty.

  • Your problem is solved. If you have more problems with the grub, download grub-repair, and burn it on a disc. It may be useful in case of... . You can always boot with this CD, and automatically repair the boot section.sourceforge.net/projects/boot-repair/?source=directory Jun 9 '12 at 9:36
  • I had the same damn problem too when clicking 'install side by side'. I knew I should've configured it myself -_- Dec 4 '12 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.