I have a problem with Ubuntu software center. It is "Searching" and "applying changes" for long period of time. I tired to cancel by clicking cross(X) mark. However, it is now stuck at "cancelling". It won't let me download any new application even from terminal i guess.

neal@neal-G50VT:~$ sudo apt-get install gnome-tweak-tool
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
neal@neal-G50VT:~$ sudo dpkg --configure -a
dpkg: error: dpkg status database is locked by another process

There are similar question here, but with no answers:

Software Center stuck for Dropbox

Software Center freezes during “applying changes

  • I would try doing killall software-center. That should terminate software center. You may need to killall dpkg if there's still the "installation" stuffs in the background.
    – Thomas Ward
    Jun 5, 2012 at 13:43
  • Tired this too. But no luck.
    – nebula
    Jun 5, 2012 at 14:24
  • try adding the -9 argument to them, so its killall -9 software-center and killall -9 dpkg
    – Thomas Ward
    Jun 5, 2012 at 14:25

10 Answers 10


I had the same issue too. However, I tried the following. Ran

sudo lsof /var/lib/dpkg/lock

From there I identified the PID of the process causing my dpkg to lock. Then I did

sudo kill -TERM <PID>

Next, I did a

 sudo dpkg --configure -a

and waited for the result... after that i did a regular

sudo apt-get update && sudo apt-get upgrade

Hope it will work for you too.

  • @ucefkh , Please thank me by up-voting the answer so that everyone else could find the best solution for such problem.. Oct 1, 2013 at 10:32
  • i did , good job
    – ucefkh
    Oct 1, 2013 at 14:14
  • 1
    when I run the sudo lsof /var/lib/dpkg/lock it says lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs Output information may be incomplete. I am having the same problem in Ubuntu 14.4
    – Waqas
    May 16, 2014 at 13:38
  • 1
    Worked for to resolve the same issue described by the original question in 15.04. Thanks!
    – bhotel
    Jun 8, 2015 at 7:24

Make sure there isn't a dialog window somewhere that needs your input to allow the installation to proceed.

In a similar situation, you see, kill -9 worked for me. But then when I started Ubuntu Software Center again it was still stuck in the same spot. Until I closed all the open windows and saw that it was waiting for me to enter an answer. Duh. Software then finished installing.

  • 1
    dialog window buried under other windows was the issue for me.
    – smcg
    May 31, 2016 at 20:02

Try to search for and terminate the /usr/bin/dpkg process:

Gabriel@UMWC:~$ ps ax | grep dpkg
 2058 pts/0    SNs+   0:00 /usr/bin/dpkg --status-fd 14 --configure -a --force-confdef --force-confold
 2061 pts/0    SN+    0:00 /bin/sh /var/lib/dpkg/info/nautilus-dropbox.postinst configure 
 2275 pts/2    S+     0:00 grep --color=auto dpkg
Gabriel@UMWC:~$ sudo kill 2058

I was experiencing this same problem using 12.04 and trying to install dropbox. The approaches here were not working for me; I wasn't even able to remove and reinstall software center. The solution from this page solved my problem, and I don't see this solution here: https://bugs.launchpad.net/ubuntu/+source/nautilus-dropbox/+bug/1016559

Specifically, the answer #9 provided by Patrick:

Run, as you did before:

sudo dpkg --configure -a

Press CONTROL+C to before the download of Dropbox [gets to 99%].

Remove dropbox:

sudo apt-get purge nautilus-dropbox

The instructions to install dropbox is provided by the dropbox website. Use this command to install (for 64-bit):

cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -

and then run it using:


For a similar problem, I removed and reinstalled the software-center and killed dpkg, then ran sudo apt-get update. After that I upgraded the packages.

  • 2
    Do you mean something like sudo pkill dpkg ?
    – belacqua
    Nov 20, 2012 at 0:23

i found that searching for the dpkg and sudo kill the process made the software center unresponsive which worked out well because all i had to do is reinstall software center.

sudo apt-get remove software-center

sudo apt-get autoremove software-center

To re-install Software Center:

sudo apt-get update

sudo apt-get install software-center

seems to work for me (note that i had tryed reinstalling before killing the dpkg and it still was stuck on "applying changes" so make sure to not skip out on that. :) hope this helps someone


The best solution to these , is this:

sudo apt-get remove software-center
sudo apt-get autoremove software-center

To re-install Software Center:

sudo apt-get update
sudo apt-get install software-center
  • This answer is practically identical to the answer from jon. Please read all the answer before writing yours. Additionally, thanks and personal comments are not expected in this site (to thanks, upvote an answer or a comment).
    – Rmano
    Nov 12, 2013 at 3:22
  • Note that anything after autoremove does nothing - autoremove removes any and all automatically installed packages that are no longer required. In general, re-installation is rarely necessary. You should certainly try reconfiguring the package (sudo dpkg-reconfigure software-center) before doing anything drastic.
    – chronitis
    Nov 12, 2013 at 12:53

Before deleting locks or killing anything, close all windows and make sure there is not a EULA popped up behind the Software Centre. These EULAs are very common, especially with software outside of the main repositories.

if that fails follow the other suggestions to unlock and kill the install process and try

sudo apt-get install -f


dpkg --configure -a 

When this happened to me, it was because I had inadvertently installed "apt-listchanges". Remove the package to see if it resolves the issue:

sudo apt-get remove apt-listchanges

Good luck.


You could try a reboot.

It would solve your problem.

  • Software Center will just pick up where it left off, on most systems. Apr 27, 2013 at 3:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .