1

Trying to login after upgrading to 23.04 via the GUI prompt. It warns of the dangers of not disabling your lock screen, but I was sure I didn't have a lock screen enabled.

The login prompt pops up, with my username, and a login button, which when clicked causes a blank screen for a second, then the same login screen pops up again.

I can select user "Other..." instead of my full name, and then put in my username, and try either my admin password, or blank (I don't use a login password), but nothing works, just prompts the login loop again. If I put my username into that box, the password box then disappears. I can enter my password first, then enter my username, but if I click tab after entering the username, the password box disappears again.

Based on this, possibly it could be solved by removing nvidia drivers, but my correct login info doesn't work in tty2. There was a question about that here, but never answered. Perhaps I could remove the drivers from the root prompt using the recovery boot option?

I reset my password using this, but nothing changes.

Any advice very gratefully received. Thanks!

Edit: an answer to this suggests I should disable AutomaticLoginEnable in /etc/gdm3/custom.conf but the gdm3 folder doesn't exist in 23.04. Does anyone know where this setting now lives?

Ok, looks like lightdm is my /etc/X11/default-display-manager; /etc/lightdm/lightdm.conf has:

autologin-session=xubuntu autologin-user=me autologin-user-timeout=0

Based on online suggestions, I commented out the last 2 lines, saved, rebooted, aaaaand, no change. Based on a different suggestion I uncommented and then deleted my name from the second line. Also no change.

Edit: Next, nano /etc/group and commented out line beginning 'nopasswdlogin'. This at least prompts me for my password, which I have successfully changed/confirmed multiple times with "passwd". It doesn't work.

Edit: added a new user in recovery mode, set a password, added to sudo, password incorrect. Remove passwords from main & new user in /etc/shadow, now in the GUI login prompt it says "Failed to authenticate" before I enter my password. And actually the password field is greyed out.

PASSWORD BIT SOLVED (for tty): I previously tried & failed to use my yubikey to login to my system, involving adding requirements to pam.d (see here). I've commented those out and now can login to tty. Now to try the display drivers thing.

More updates: purged nvidia drivers, lspci now says the graphics card has no active driver. Still no idea how to actually select the nouveau driver outside of the GUI - it's already installed, and I backed up and removed xorg.conf to prompt it to rebuild that from scratch, still nothing.

Based on this, grep nouveau /var/log/Xorg.0.log:

(II) LoadModule: "nouveau"

(II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so

(II) Module nouveau: vendor="X.Org Foundation"

(==) Matched nouveau as autoconfigured driver 0

(II) LoadModule: "nouveau"

(II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so

(II) Module nouveau: vendor="X.Org Foundation"

(II) UnloadModule: "nouveau"

(II) Unloading nouveau

(II) Failed to load module "nouveau" (already loaded, 0)

It looks like it's trying to load it twice?

lsmod | grep nouveau

Suggests it is loaded.

lspci -nnk | grep -iA2 vga

Should show which driver is in use but the result is:

"grep: vga: No such file or directory".

Completely stumped as to how to get it to use this driver.

sudo lshw -c video

Gives some interesting bits:

*-display UNCLAIMED configuration: latency=0

I.e. no driver again, and unclaimed, whatever that means.

lspci -nnk | grep -i vga -A3 | grep 'Kernel modules'

nvidiafb, nouveau

More: this says I can bind a module (nouveau) to a device (nvidia gpu) but there's no nvidia gpu in /sys/bus/pci/drivers/.

This has various useful approaches but nothing if there's no driver loaded, other than it's not loaded (comments on answer 1). The user said "When booting via BIOS, X ends up using VESA driver, but when booting via UEFI, X cannot start at all" but IDK how they came to this conclusion.

This says you can blacklist modules but nouveau isn't blacklisted (I checked).

4
  • 1
    It's strange your credentials aren't working in tty2. You could try to boot recovery, chroot and change your password.
    – undefined
    May 16, 2023 at 17:21
  • Thanks. I've tried that, confirming my username beforehand then "passwd", enter password trice, confirmed it works, no change. Chroot though? When booting to recovery you're in the root account by default no? Perhaps my password changes look like they're working but aren't saving...?
    – dez93_2000
    May 16, 2023 at 17:56
  • Followed this: askubuntu.com/questions/24006/… and successfully changed user password (evidently I changed the root password successfully before). Reboot. Login. Password incorrect. Baffling.
    – dez93_2000
    May 16, 2023 at 18:03
  • 1
    I am not sure about your case, but when I once had to reset a root password on a server through rescue I had to chroot. For the specific rescue system on my Hetzner server I followed their guide. It's worth noting it probably only works for their rescue system.
    – undefined
    May 17, 2023 at 7:47

1 Answer 1

0

PASSWORD BIT SOLVED (for tty): I previously tried & failed to use my yubikey to login to my system, involving adding requirements to pam.d (see here). I've commented those out and now can login to tty. Now to try the display drivers thing.

That was solved in this separate thread.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .