I was trying to install yelp-tools. I ran sudo apt-get update && sudo apt-get upgrade then sudo apt-get install yelp-tools it fails with this:

E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/libx/libxml2/python3-libxml2_2.9.13%2bdfsg-1ubuntu0.2_amd64.deb  404  Not Found [IP: 80]

sudo apt-get install --fix-missing yelp-tools returns the same error.

looking in the repo: there is no package for libxml2_2.9.13%2bdfsg-1ubuntu0.2_amd64.deb

rather it is: libxml2_2.9.13%2bdfsg-1ubuntu0.3_amd64.deb

I would suspect somewhere, there is a package listing pointing to a package that doesn't exist due to a typo.

where is the index file for the repo http://security.ubuntu.com/ubuntu jammy-security universe

apt-get update updates the package index files. where are those index files exactly? I think there is a typo in one of them.

the problem goes on, from there, but its all the same type of error. I installed the newer libxml2_2.9.13%2bdfsg-1ubuntu0.3_amd64.deb package, then installed yelp-tools and it worked. but I think there must be an error in the package index, should I contact someone? how can I verify?

  • Check your apt update output for failed index downbloads. This kind of 404 error usually occurs when an incomplete update leaves your local indexes out-of-date.
    – user535733
    May 9 at 19:03

1 Answer 1


The actual index URLs are listed in your apt update output.

Here's an example from 23.04:

$ sudo apt update
[sudo] password for the_admin: 
Hit:1 http://us.archive.ubuntu.com/ubuntu lunar InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu lunar-updates InRelease [90.7 kB]
Get:3 http://security.ubuntu.com/ubuntu lunar-security InRelease [90.7 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu lunar-updates/main amd64 Packages [13.9 kB]

Let's drill into that first line:

http://us.archive.ubuntu.com/ubuntu lunar InRelease

Opening that URL reveals the actual package index.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .